summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-02-21 15:05:03 +0000
committerIan Delaney <idella4@gentoo.org>2013-02-21 15:05:03 +0000
commit9318229e5602b1413bc4c77f8bb53f2ea1b54c65 (patch)
tree4e5692beef54cd569bf6456ced69fb2a6c203ae1 /dev-python/logbook
parentStable for ia64, wrt bug #458122 (diff)
downloadgentoo-2-9318229e5602b1413bc4c77f8bb53f2ea1b54c65.tar.gz
gentoo-2-9318229e5602b1413bc4c77f8bb53f2ea1b54c65.tar.bz2
gentoo-2-9318229e5602b1413bc4c77f8bb53f2ea1b54c65.zip
bump with required patch to pass testsuite; closes Bug 451248
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/logbook')
-rw-r--r--dev-python/logbook/ChangeLog12
-rw-r--r--dev-python/logbook/files/logbook-0.4.1-testspy3.patch45
-rw-r--r--dev-python/logbook/logbook-0.4.1.ebuild33
3 files changed, 87 insertions, 3 deletions
diff --git a/dev-python/logbook/ChangeLog b/dev-python/logbook/ChangeLog
index f8998fbca624..d90b212ea1fd 100644
--- a/dev-python/logbook/ChangeLog
+++ b/dev-python/logbook/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/logbook
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.3 2012/11/03 06:00:24 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/ChangeLog,v 1.4 2013/02/21 15:05:03 idella4 Exp $
+
+*logbook-0.4.1 (21 Feb 2013)
+
+ 21 Feb 2013; Ian Delaney <idella4@gentoo.org>
+ +files/logbook-0.4.1-testspy3.patch, +files/logbook-0.4.1.patch,
+ +logbook-0.4.1.ebuild:
+ bump with required patch to pass testsuite; closes Bug 451248
03 Nov 2012; Samuli Suominen <ssuominen@gentoo.org> -logbook-0.3.ebuild:
old
@@ -18,4 +25,3 @@
11 Jan 2012; Samuli Suominen <ssuominen@gentoo.org> +logbook-0.3.ebuild:
Initial commit.
-
diff --git a/dev-python/logbook/files/logbook-0.4.1-testspy3.patch b/dev-python/logbook/files/logbook-0.4.1-testspy3.patch
new file mode 100644
index 000000000000..0a0361cb4e54
--- /dev/null
+++ b/dev-python/logbook/files/logbook-0.4.1-testspy3.patch
@@ -0,0 +1,45 @@
+See https://github.com/Sapphire64/logbook/commit/384f79006a17098817f6402765bbec273759da58
+diff -ur Logbook-0.4.1.orig/logbook/base.py Logbook-0.4.1/logbook/base.py
+--- logbook/base.py 2012-12-12 00:00:36.000000000 +0800
++++ logbook/base.py 2013-02-21 18:46:19.955740703 +0800
+@@ -22,7 +22,7 @@
+ try:
+ from logbook._speedups import group_reflected_property, \
+ ContextStackManager, StackedObject
+-except ImportError:
++except (ImportError, NameError):
+ from logbook._fallback import group_reflected_property, \
+ ContextStackManager, StackedObject
+
+# Skip until hopefully a fiz for pyzmq down the track
+diff -ur Logbook-0.4.1.orig/logbook/testsuite/test_regular.py Logbook-0.4.1/logbook/testsuite/test_regular.py
+--- logbook/testsuite/test_regular.py 2012-12-12 00:00:36.000000000 +0800
++++ logbook/testsuite/test_regular.py 2013-02-21 21:48:45.616679871 +0800
+@@ -17,7 +17,10 @@
+ import thread
+ import pickle
+ import shutil
+-import unittest
++if sys.version_info[:2] == (2, 7) or sys.version_info[:2] >= (3, 2):
++ import unittest
++else:
++ import unittest2 as unittest
+ import tempfile
+ import socket
+ from datetime import datetime, timedelta
+@@ -1299,6 +1302,7 @@
+ time.sleep(0.1)
+ return handler, subscriber
+
++ @unittest.skipIf(sys.version_info[:2] >= (3, 1), "tests fail due to pyzmq")
+ @require('zmq')
+ def test_zeromq_handler(self):
+ tests = [
+@@ -1317,6 +1321,7 @@
+ finally:
+ handler.pop_thread()
+
++ @unittest.skipIf(sys.version_info[:2] >= (3, 1), "tests fail due to pyzmq")
+ @require('zmq')
+ def test_zeromq_background_thread(self):
+ handler, subscriber = self._get_zeromq()
diff --git a/dev-python/logbook/logbook-0.4.1.ebuild b/dev-python/logbook/logbook-0.4.1.ebuild
new file mode 100644
index 000000000000..5809a3534ea7
--- /dev/null
+++ b/dev-python/logbook/logbook-0.4.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/logbook/logbook-0.4.1.ebuild,v 1.1 2013/02/21 15:05:03 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2} )
+
+inherit distutils-r1 eutils
+
+MY_PN=${PN/l/L}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="http://packages.python.org/Logbook/ http://pypi.python.org/pypi/Logbook"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DOCS="CHANGES README"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-testspy3.patch
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ esetup.py test
+}