summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-06-16 01:51:57 +0000
committerIan Delaney <idella4@gentoo.org>2014-06-16 01:51:57 +0000
commit91b6897957c882cd508f6ea2df4765c93325f370 (patch)
tree7f1bae2288963f3e5a313308e709ffb82f93d32c /dev-python/msgpack
parentPut back 334.21 for now (bug #513380). (diff)
downloadgentoo-2-91b6897957c882cd508f6ea2df4765c93325f370.tar.gz
gentoo-2-91b6897957c882cd508f6ea2df4765c93325f370.tar.bz2
gentoo-2-91b6897957c882cd508f6ea2df4765c93325f370.zip
shed un-needed dep nose, fix test phase
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/msgpack')
-rw-r--r--dev-python/msgpack/ChangeLog5
-rw-r--r--dev-python/msgpack/msgpack-0.4.2.ebuild10
2 files changed, 6 insertions, 9 deletions
diff --git a/dev-python/msgpack/ChangeLog b/dev-python/msgpack/ChangeLog
index cf45101c583f..d54c0db80c02 100644
--- a/dev-python/msgpack/ChangeLog
+++ b/dev-python/msgpack/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/msgpack
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/msgpack/ChangeLog,v 1.19 2014/06/15 11:33:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/msgpack/ChangeLog,v 1.20 2014/06/16 01:51:57 idella4 Exp $
+
+ 16 Jun 2014; Ian Delaney <idella4@gentoo.org> msgpack-0.4.2.ebuild:
+ shed un-needed dep nose, fix test phase
15 Jun 2014; Ian Delaney <idella4@gentoo.org> msgpack-0.4.2.ebuild:
drop py2.6 add pypy supp., update test phase accordingly
diff --git a/dev-python/msgpack/msgpack-0.4.2.ebuild b/dev-python/msgpack/msgpack-0.4.2.ebuild
index 567c1d74ee5d..790c26dc0ade 100644
--- a/dev-python/msgpack/msgpack-0.4.2.ebuild
+++ b/dev-python/msgpack/msgpack-0.4.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/msgpack/msgpack-0.4.2.ebuild,v 1.2 2014/06/15 11:33:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/msgpack/msgpack-0.4.2.ebuild,v 1.3 2014/06/16 01:51:57 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
@@ -23,16 +23,10 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
test? (
dev-python/six[${PYTHON_USEDEP}]
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
)"
S="${WORKDIR}/${MY_P}"
-DISTUTILS_IN_SOURCE_BUILD=1
python_test() {
- # https://github.com/msgpack/msgpack/issues/173
- if [[ "${EPYTHON}" == pypy ]]; then
- sed -e s':test_unpacker_hook_refcnt:_&:' -i test/test_unpack.py || die
- fi
- nosetests -P -w test || die "Tests fail with ${EPYTHON}"
+ py.test test || die "Tests fail with ${EPYTHON}"
}