summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-09 16:34:56 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-09 16:34:56 +0000
commit63ab8dfd694a69c8624a4976bf0ae4256cb54c64 (patch)
treee74ddfeb1c184c0c72a9b3fea86c7c15741dc7b6 /dev-python/nevow
parentfreebsd_src_compile: forward arguments to bsdmk_src_compile (diff)
downloadgentoo-2-63ab8dfd694a69c8624a4976bf0ae4256cb54c64.tar.gz
gentoo-2-63ab8dfd694a69c8624a4976bf0ae4256cb54c64.tar.bz2
gentoo-2-63ab8dfd694a69c8624a4976bf0ae4256cb54c64.zip
Migrate to twisted-r1.
(Portage version: 2.2.0_alpha196/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/nevow')
-rw-r--r--dev-python/nevow/ChangeLog7
-rw-r--r--dev-python/nevow/nevow-0.10.0-r1.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/dev-python/nevow/ChangeLog b/dev-python/nevow/ChangeLog
index 90a5c7731c20..1c27f79f40b3 100644
--- a/dev-python/nevow/ChangeLog
+++ b/dev-python/nevow/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/nevow
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/ChangeLog,v 1.48 2013/08/03 09:45:48 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/ChangeLog,v 1.49 2013/08/09 16:34:56 mgorny Exp $
+
+*nevow-0.10.0-r1 (09 Aug 2013)
+
+ 09 Aug 2013; Michał Górny <mgorny@gentoo.org> +nevow-0.10.0-r1.ebuild:
+ Migrate to twisted-r1.
03 Aug 2013; Michał Górny <mgorny@gentoo.org> nevow-0.10.0.ebuild:
Move dev-python/twisted to dev-python/twisted-core.
diff --git a/dev-python/nevow/nevow-0.10.0-r1.ebuild b/dev-python/nevow/nevow-0.10.0-r1.ebuild
new file mode 100644
index 000000000000..9ef10e5369ae
--- /dev/null
+++ b/dev-python/nevow/nevow-0.10.0-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nevow/nevow-0.10.0-r1.ebuild,v 1.1 2013/08/09 16:34:56 mgorny Exp $
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_6,2_7} )
+
+inherit twisted-r1
+
+DESCRIPTION="A web templating framework that provides LivePage, an automatic AJAX toolkit."
+HOMEPAGE="http://divmod.org/trac/wiki/DivmodNevow http://pypi.python.org/pypi/Nevow"
+SRC_URI="mirror://pypi/${TWISTED_PN:0:1}/${TWISTED_PN}/${TWISTED_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-linux"
+IUSE="doc"
+
+DEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/twisted-web[${PYTHON_USEDEP}]
+ net-zope/zope-interface[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+TWISTED_PLUGINS=( nevow.plugins )
+
+python_test() {
+ trial formless nevow || die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ # TODO: prevent installing it
+ rm -r "${D}"/usr/doc || die
+}