summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-07-08 00:51:32 +0000
committerIan Delaney <idella4@gentoo.org>2014-07-08 00:51:32 +0000
commitc0a953e77f485ba928f5e01bbeeaef5b72c3fd96 (patch)
treeb84d232ac4e3c3626f991241587749f49feb343c /dev-python/nose-exclude
parentUse eautoconf #515410. Updated to EAPI=5 (diff)
downloadgentoo-2-c0a953e77f485ba928f5e01bbeeaef5b72c3fd96.tar.gz
gentoo-2-c0a953e77f485ba928f5e01bbeeaef5b72c3fd96.tar.bz2
gentoo-2-c0a953e77f485ba928f5e01bbeeaef5b72c3fd96.zip
bump; add test phase but phase restricted for now due to failures
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/nose-exclude')
-rw-r--r--dev-python/nose-exclude/ChangeLog7
-rw-r--r--dev-python/nose-exclude/nose-exclude-0.2.0.ebuild25
2 files changed, 31 insertions, 1 deletions
diff --git a/dev-python/nose-exclude/ChangeLog b/dev-python/nose-exclude/ChangeLog
index f00f56c02be6..01676708284c 100644
--- a/dev-python/nose-exclude/ChangeLog
+++ b/dev-python/nose-exclude/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/nose-exclude
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-exclude/ChangeLog,v 1.5 2014/07/07 15:08:49 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-exclude/ChangeLog,v 1.6 2014/07/08 00:51:32 idella4 Exp $
+
+*nose-exclude-0.2.0 (08 Jul 2014)
+
+ 08 Jul 2014; Ian Delaney <idella4@gentoo.org> +nose-exclude-0.2.0.ebuild:
+ bump; add test phase but phase restricted for now due to failures
07 Jul 2014; Ian Delaney <idella4@gentoo.org> nose-exclude-0.1.9.ebuild:
add py3.4
diff --git a/dev-python/nose-exclude/nose-exclude-0.2.0.ebuild b/dev-python/nose-exclude/nose-exclude-0.2.0.ebuild
new file mode 100644
index 000000000000..4cc03668630b
--- /dev/null
+++ b/dev-python/nose-exclude/nose-exclude-0.2.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nose-exclude/nose-exclude-0.2.0.ebuild,v 1.1 2014/07/08 00:51:32 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_2,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Exclude specific directories from nosetests runs."
+HOMEPAGE="http://bitbucket.org/kgrandis/nose-exclude"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/nose[${PYTHON_USEDEP}]"
+RESTRICT="test"
+
+python_test() {
+ # https://bitbucket.org/kgrandis/nose-exclude/issue/10/test-failures-with-python-3
+ esetup.py test
+}