summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-06-18 06:50:46 +0000
committerIan Delaney <idella4@gentoo.org>2013-06-18 06:50:46 +0000
commit88ce12b8c41cca2d4c8a8769080b0d8629e5958c (patch)
tree61cff8287f0aa26240d39ce97972e9fda6be3379 /dev-python/nosexcover
parentsci-biology/sibsim4: Drop maintainer (diff)
downloadgentoo-2-88ce12b8c41cca2d4c8a8769080b0d8629e5958c.tar.gz
gentoo-2-88ce12b8c41cca2d4c8a8769080b0d8629e5958c.tar.bz2
gentoo-2-88ce12b8c41cca2d4c8a8769080b0d8629e5958c.zip
revbump, migrate -> distutils-r1, bump; add full py3 support
(Portage version: 2.1.11.63/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/nosexcover')
-rw-r--r--dev-python/nosexcover/ChangeLog9
-rw-r--r--dev-python/nosexcover/nosexcover-1.0.7-r1.ebuild23
-rw-r--r--dev-python/nosexcover/nosexcover-1.0.8.ebuild23
3 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/nosexcover/ChangeLog b/dev-python/nosexcover/ChangeLog
index 83e386b29cd3..daf5698222ed 100644
--- a/dev-python/nosexcover/ChangeLog
+++ b/dev-python/nosexcover/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/nosexcover
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/nosexcover/ChangeLog,v 1.2 2013/01/02 20:02:05 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nosexcover/ChangeLog,v 1.3 2013/06/18 06:50:46 idella4 Exp $
+
+*nosexcover-1.0.8 (18 Jun 2013)
+*nosexcover-1.0.7-r1 (18 Jun 2013)
+
+ 18 Jun 2013; Ian Delaney <idella4@gentoo.org> +nosexcover-1.0.7-r1.ebuild,
+ +nosexcover-1.0.8.ebuild:
+ revbump, migrate -> distutils-r1, bump; add full py3 support
02 Jan 2013; Matthew Thode <prometheanfire@gentoo.org>
nosexcover-1.0.7.ebuild:
diff --git a/dev-python/nosexcover/nosexcover-1.0.7-r1.ebuild b/dev-python/nosexcover/nosexcover-1.0.7-r1.ebuild
new file mode 100644
index 000000000000..abcaad391a6b
--- /dev/null
+++ b/dev-python/nosexcover/nosexcover-1.0.7-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nosexcover/nosexcover-1.0.7-r1.ebuild,v 1.1 2013/06/18 06:50:46 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extends nose.plugins.cover to add Cobertura-style XML reports"
+HOMEPAGE="https://github.com/cmheisel/nose-xcover/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
diff --git a/dev-python/nosexcover/nosexcover-1.0.8.ebuild b/dev-python/nosexcover/nosexcover-1.0.8.ebuild
new file mode 100644
index 000000000000..761a5d42dd8e
--- /dev/null
+++ b/dev-python/nosexcover/nosexcover-1.0.8.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/nosexcover/nosexcover-1.0.8.ebuild,v 1.1 2013/06/18 06:50:45 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy{1_9,2_0} )
+
+inherit distutils-r1
+
+DESCRIPTION="Extends nose.plugins.cover to add Cobertura-style XML reports"
+HOMEPAGE="https://github.com/cmheisel/nose-xcover/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"