summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-01-10 17:38:36 +0000
committerJustin Lecher <jlec@gentoo.org>2013-01-10 17:38:36 +0000
commit58f3b1564e08dcc5641ede6b10f744ff1930ad22 (patch)
treee319c751d51819872b2917ce1b0a0fd85a6f8dec /dev-python/numpy
parentsci-chemistry/ccp4-apps: Add fix for tcl-8.6 (diff)
downloadgentoo-2-58f3b1564e08dcc5641ede6b10f744ff1930ad22.tar.gz
gentoo-2-58f3b1564e08dcc5641ede6b10f744ff1930ad22.tar.bz2
gentoo-2-58f3b1564e08dcc5641ede6b10f744ff1930ad22.zip
dev-python/numpy: Cleaned old
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-python/numpy')
-rw-r--r--dev-python/numpy/ChangeLog9
-rw-r--r--dev-python/numpy/metadata.xml6
-rw-r--r--dev-python/numpy/numpy-1.6.1-r1.ebuild138
3 files changed, 10 insertions, 143 deletions
diff --git a/dev-python/numpy/ChangeLog b/dev-python/numpy/ChangeLog
index 335fe2e62038..19abbfa46ad5 100644
--- a/dev-python/numpy/ChangeLog
+++ b/dev-python/numpy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/numpy
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.180 2012/12/29 17:45:46 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/ChangeLog,v 1.181 2013/01/10 17:38:36 jlec Exp $
+
+ 10 Jan 2013; Justin Lecher <jlec@gentoo.org> -numpy-1.6.1-r1.ebuild,
+ metadata.xml:
+ Cleaned old
+
29 Dec 2012; Raúl Porcel <armin76@gentoo.org> numpy-1.6.2.ebuild:
alpha/s390/sh/sparc stable wrt #446340
diff --git a/dev-python/numpy/metadata.xml b/dev-python/numpy/metadata.xml
index 067cfe3be15b..3ee58f645122 100644
--- a/dev-python/numpy/metadata.xml
+++ b/dev-python/numpy/metadata.xml
@@ -1,9 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>sci</herd>
- <herd>python</herd>
- <longdescription lang="en">
+ <herd>sci</herd>
+ <herd>python</herd>
+ <longdescription lang="en">
NumPy is a general-purpose array-processing Python package designed to
efficiently manipulate large multi-dimensional arrays of arbitrary
records without sacrificing too much speed for small multi-dimensional
diff --git a/dev-python/numpy/numpy-1.6.1-r1.ebuild b/dev-python/numpy/numpy-1.6.1-r1.ebuild
deleted file mode 100644
index c81566b1bc6b..000000000000
--- a/dev-python/numpy/numpy-1.6.1-r1.ebuild
+++ /dev/null
@@ -1,138 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/numpy/numpy-1.6.1-r1.ebuild,v 1.15 2012/10/16 18:38:04 jlec Exp $
-
-EAPI=3
-
-PYTHON_DEPEND="*"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-*"
-
-FORTRAN_NEEDED=lapack
-
-inherit distutils eutils flag-o-matic fortran-2 toolchain-funcs versionator
-
-DOC_P="${PN}-1.6.0"
-
-DESCRIPTION="Fast array and numerical python library"
-HOMEPAGE="http://numpy.scipy.org/ http://pypi.python.org/pypi/numpy"
-SRC_URI="mirror://sourceforge/numpy/${P}.tar.gz
- doc? (
- http://docs.scipy.org/doc/${DOC_P}/numpy-html.zip -> ${DOC_P}-html.zip
- http://docs.scipy.org/doc/${DOC_P}/numpy-ref.pdf -> ${DOC_P}-ref.pdf
- http://docs.scipy.org/doc/${DOC_P}/numpy-user.pdf -> ${DOC_P}-user.pdf
- )"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc lapack test"
-
-RDEPEND="
- dev-python/setuptools
- lapack? ( virtual/cblas virtual/lapack )"
-DEPEND="${RDEPEND}
- doc? ( app-arch/unzip )
- lapack? ( virtual/pkgconfig )
- test? ( >=dev-python/nose-0.10 )"
-
-PYTHON_CFLAGS=("* + -fno-strict-aliasing")
-
-# Build system installs f2py${Python_version} scripts.
-PYTHON_NONVERSIONED_EXECUTABLES=("/usr/bin/f2py[[:digit:]]+\.[[:digit:]]+")
-
-DOCS="COMPATIBILITY DEV_README.txt THANKS.txt"
-
-pkg_setup() {
- fortran-2_pkg_setup
- python_pkg_setup
-
- # See progress in http://projects.scipy.org/scipy/numpy/ticket/573
- # with the subtle difference that we don't want to break Darwin where
- # -shared is not a valid linker argument
- if [[ ${CHOST} != *-darwin* ]]; then
- append-ldflags -shared
- fi
-
- # only one fortran to link with:
- # linking with cblas and lapack library will force
- # autodetecting and linking to all available fortran compilers
- if use lapack; then
- append-fflags -fPIC
- NUMPY_FCONFIG="config_fc --noopt --noarch"
- # workaround bug 335908
- [[ ${FC} == *gfortran* ]] && NUMPY_FCONFIG+=" --fcompiler=gnu95"
- fi
-}
-
-src_unpack() {
- unpack ${P}.tar.gz
- if use doc; then
- unzip -qo "${DISTDIR}"/${DOC_P}-html.zip -d html || die
- fi
-}
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-atlas.patch
- epatch "${FILESDIR}"/${P}-import_umath.patch
-
- if use lapack; then
- append-ldflags "$(pkg-config --libs-only-other cblas lapack)"
- sed -i -e '/NO_ATLAS_INFO/,+1d' numpy/core/setup.py || die
- local libdir="${EPREFIX}"/usr/$(get_libdir)
- cat >> site.cfg <<-EOF
- [blas]
- include_dirs = $(pkg-config --cflags-only-I \
- cblas | sed -e 's/^-I//' -e 's/ -I/:/g')
- library_dirs = $(pkg-config --libs-only-L \
- cblas blas | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- blas_libs = $(pkg-config --libs-only-l \
- cblas blas | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- [lapack]
- library_dirs = $(pkg-config --libs-only-L \
- lapack | sed -e 's/^-L//' -e 's/ -L/:/g' -e 's/ //g'):${libdir}
- lapack_libs = $(pkg-config --libs-only-l \
- lapack | sed -e 's/^-l//' -e 's/ -l/, /g' -e 's/,.pthread//g')
- EOF
- else
- export {ATLAS,PTATLAS,BLAS,LAPACK,MKL}=None
- fi
-
- export CC="$(tc-getCC) ${CFLAGS}"
-}
-
-src_compile() {
- distutils_src_compile ${NUMPY_FCONFIG}
-}
-
-src_test() {
- testing() {
- "$(PYTHON)" setup.py ${NUMPY_FCONFIG} build -b "build-${PYTHON_ABI}" install \
- --home="${S}/test-${PYTHON_ABI}" --no-compile || die "install test failed"
- pushd "${S}/test-${PYTHON_ABI}/"lib* > /dev/null
- PYTHONPATH=python "$(PYTHON)" -c "import numpy; numpy.test()" 2>&1 | tee test.log
- grep -Eq "^(ERROR|FAIL):" test.log && return 1
- popd > /dev/null
- rm -fr test-${PYTHON_ABI}
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install ${NUMPY_FCONFIG}
-
- delete_txt() {
- rm -f "${ED}"$(python_get_sitedir)/numpy/*.txt
- }
- python_execute_function -q delete_txt
-
- docinto f2py
- dodoc numpy/f2py/docs/*.txt || die "dodoc f2py failed"
- doman numpy/f2py/f2py.1 || die "doman failed"
-
- if use doc; then
- insinto /usr/share/doc/${PF}
- doins -r "${WORKDIR}"/html || die
- doins "${DISTDIR}"/${DOC_P}*pdf || die
- fi
-}