summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-01-22 06:55:35 +0000
committerIan Delaney <idella4@gentoo.org>2013-01-22 06:55:35 +0000
commit871ac005bea3321050f9edc078e1f48613a1fc2c (patch)
tree3087252d3fd762175369a5af7d1c32c0338064ed /dev-python/oct2py
parentBump (diff)
downloadgentoo-2-871ac005bea3321050f9edc078e1f48613a1fc2c.tar.gz
gentoo-2-871ac005bea3321050f9edc078e1f48613a1fc2c.tar.bz2
gentoo-2-871ac005bea3321050f9edc078e1f48613a1fc2c.zip
bump
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/oct2py')
-rw-r--r--dev-python/oct2py/ChangeLog9
-rw-r--r--dev-python/oct2py/oct2py-0.4.0.ebuild42
2 files changed, 49 insertions, 2 deletions
diff --git a/dev-python/oct2py/ChangeLog b/dev-python/oct2py/ChangeLog
index d11c0d07740c..1fe9f82e0f59 100644
--- a/dev-python/oct2py/ChangeLog
+++ b/dev-python/oct2py/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/oct2py
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.6 2012/12/11 18:25:34 bicatali Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/ChangeLog,v 1.7 2013/01/22 06:55:35 idella4 Exp $
+
+*oct2py-0.4.0 (22 Jan 2013)
+
+ 22 Jan 2013; Ian Delaney <idella4@gentoo.org> +oct2py-0.4.0.ebuild:
+ bump
11 Dec 2012; Sébastien Fabbro <bicatali@gentoo.org> -oct2py-0.3.2.ebuild,
-oct2py-0.3.4.ebuild:
diff --git a/dev-python/oct2py/oct2py-0.4.0.ebuild b/dev-python/oct2py/oct2py-0.4.0.ebuild
new file mode 100644
index 000000000000..d07c637d416d
--- /dev/null
+++ b/dev-python/oct2py/oct2py-0.4.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oct2py/oct2py-0.4.0.ebuild,v 1.1 2013/01/22 06:55:35 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python to GNU Octave bridge"
+HOMEPAGE="http://pypi.python.org/pypi/oct2py"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc examples"
+
+RDEPEND="sci-libs/scipy
+ sci-mathematics/octave"
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx )"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build doc html || die
+ fi
+}
+
+python_test() {
+ nosetests || die
+}
+
+python_install_all() {
+ use doc && dohtml -r html/
+ if use examples; then
+ docompress -x /usr/share/doc/${PF}/example
+ insinto /usr/share/doc/${PF}/
+ doins -r example/
+ fi
+}