summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 17:21:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 17:21:47 +0000
commitcd49548eff3202c6bae0a5004621725e88fcb42d (patch)
tree1e8786d2adef40bcf15b47e050e1ed406dff49c8 /dev-python/odfpy
parentadd en-GB lang support back in. (diff)
downloadgentoo-2-cd49548eff3202c6bae0a5004621725e88fcb42d.tar.gz
gentoo-2-cd49548eff3202c6bae0a5004621725e88fcb42d.tar.bz2
gentoo-2-cd49548eff3202c6bae0a5004621725e88fcb42d.zip
Version bump.
(Portage version: 15121-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/odfpy')
-rw-r--r--dev-python/odfpy/ChangeLog8
-rw-r--r--dev-python/odfpy/odfpy-0.9.2.ebuild36
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/odfpy/ChangeLog b/dev-python/odfpy/ChangeLog
index 724d77ded1f7..d04bb61821be 100644
--- a/dev-python/odfpy/ChangeLog
+++ b/dev-python/odfpy/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/odfpy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/ChangeLog,v 1.3 2009/08/31 23:04:34 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/ChangeLog,v 1.4 2009/12/19 17:21:47 arfrever Exp $
+
+*odfpy-0.9.2 (19 Dec 2009)
+
+ 19 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +odfpy-0.9.2.ebuild:
+ Version bump.
*odfpy-0.9.1 (31 Aug 2009)
diff --git a/dev-python/odfpy/odfpy-0.9.2.ebuild b/dev-python/odfpy/odfpy-0.9.2.ebuild
new file mode 100644
index 000000000000..52cec2458374
--- /dev/null
+++ b/dev-python/odfpy/odfpy-0.9.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/odfpy/odfpy-0.9.2.ebuild,v 1.1 2009/12/19 17:21:47 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="Python API and tools to manipulate OpenDocument files"
+HOMEPAGE="http://opendocumentfellowship.com/development/projects/odfpy http://pypi.python.org/pypi/odfpy"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="odf"
+
+src_test() {
+ testing() {
+ pushd tests > /dev/null || die
+ local test
+ for test in test*.py; do
+ echo -e "\e[1;31mRunning ${test}...\e[0m"
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" || die "${test} failed with Python ${PYTHON_ABI}"
+ done
+ popd > /dev/null || die
+ }
+ python_execute_function testing
+}