summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2013-04-10 16:04:44 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2013-04-10 16:04:44 +0000
commit977826b78697649c2eca7f8d918803dba33871fd (patch)
treee41967147bc43d2ada2603b85877018d504e6b02 /dev-python/oslo-config/oslo-config-1.1.0.ebuild
parentFix spelling. (diff)
downloadgentoo-2-977826b78697649c2eca7f8d918803dba33871fd.tar.gz
gentoo-2-977826b78697649c2eca7f8d918803dba33871fd.tar.bz2
gentoo-2-977826b78697649c2eca7f8d918803dba33871fd.zip
initial add of oslo.config (as oslo-config) for sys-auth/keystone-2013.1
(Portage version: 2.1.11.55/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/oslo-config/oslo-config-1.1.0.ebuild')
-rw-r--r--dev-python/oslo-config/oslo-config-1.1.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/oslo-config/oslo-config-1.1.0.ebuild b/dev-python/oslo-config/oslo-config-1.1.0.ebuild
new file mode 100644
index 000000000000..0f649fd7c9a4
--- /dev/null
+++ b/dev-python/oslo-config/oslo-config-1.1.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/oslo-config/oslo-config-1.1.0.ebuild,v 1.1 2013/04/10 16:04:44 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_6 python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="The Oslo configuration API supports parsing command line arguments
+and ini style configuration files"
+HOMEPAGE="https://pypi.python.org/pypi/oslo.config"
+SRC_URI="mirror://pypi/${PN:0:1}/oslo.config/oslo.config-${PV}.tar.gz"
+S="${WORKDIR}/oslo.config-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+#need to package a bunch of stuff, they changed their test suite, again...
+RESTRICT="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]"