summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-02 20:25:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-11-02 20:25:44 +0000
commitc39032541cf34cf558c2f8f786221653431ec028 (patch)
tree3f889a357c0a89fb0eadbf749fea2519750170be /dev-python/paramiko/paramiko-1.7.6.ebuild
parentamd64/x86 stable, bug #290950 (diff)
downloadgentoo-2-c39032541cf34cf558c2f8f786221653431ec028.tar.gz
gentoo-2-c39032541cf34cf558c2f8f786221653431ec028.tar.bz2
gentoo-2-c39032541cf34cf558c2f8f786221653431ec028.zip
Version bump.
(Portage version: 14774-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/paramiko/paramiko-1.7.6.ebuild')
-rw-r--r--dev-python/paramiko/paramiko-1.7.6.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/paramiko/paramiko-1.7.6.ebuild b/dev-python/paramiko/paramiko-1.7.6.ebuild
new file mode 100644
index 000000000000..2b1c441ec831
--- /dev/null
+++ b/dev-python/paramiko/paramiko-1.7.6.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/paramiko/paramiko-1.7.6.ebuild,v 1.1 2009/11/02 20:25:44 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils eutils
+
+DESCRIPTION="SSH2 protocol library"
+HOMEPAGE="http://www.lag.net/paramiko/ http://pypi.python.org/pypi/paramiko"
+SRC_URI="http://www.lag.net/paramiko/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris"
+IUSE="doc examples"
+
+RDEPEND=">=dev-python/pycrypto-1.9_alpha6"
+DEPEND="${RDEPEND}
+ dev-python/setuptools"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ "$(PYTHON)" test.py --verbose
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r docs/* || die "dohtml failed"
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demos || die "doins failed"
+ fi
+}