summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2014-05-20 08:11:00 +0000
committerPatrick Lauer <patrick@gentoo.org>2014-05-20 08:11:00 +0000
commit70895bf343b85a28192f424c6ff3d1b7a50120b2 (patch)
tree83aaea5cf3e61089b3c74d8165b51ac20b313276 /dev-python/peewee
parentStop using einfo/eerror in fix_libtool_files.sh to avoid a dependency on (diff)
downloadgentoo-2-70895bf343b85a28192f424c6ff3d1b7a50120b2.tar.gz
gentoo-2-70895bf343b85a28192f424c6ff3d1b7a50120b2.tar.bz2
gentoo-2-70895bf343b85a28192f424c6ff3d1b7a50120b2.zip
Bump
(Portage version: 2.2.10/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog7
-rw-r--r--dev-python/peewee/peewee-2.1.7.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index b97a2db180eb..08d86f8f51d7 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.5 2014/05/14 23:21:07 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.6 2014/05/20 08:11:00 patrick Exp $
+
+*peewee-2.1.7 (20 May 2014)
+
+ 20 May 2014; Patrick Lauer <patrick@gentoo.org> +peewee-2.1.7.ebuild:
+ Bump
*peewee-2.1.6 (14 May 2014)
diff --git a/dev-python/peewee/peewee-2.1.7.ebuild b/dev-python/peewee/peewee-2.1.7.ebuild
new file mode 100644
index 000000000000..21f02515064d
--- /dev/null
+++ b/dev-python/peewee/peewee-2.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.1.7.ebuild,v 1.1 2014/05/20 08:11:00 patrick Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/apsw[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}