summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-20 06:20:21 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-20 06:20:21 +0000
commita4a2b15d2e4e0f880c4dbb973af2f22f2be12a09 (patch)
treee85ea712717eb30c9789f7cf271ce39d278e8bd0 /dev-python/peewee
parentVersion bump. (diff)
downloadgentoo-2-a4a2b15d2e4e0f880c4dbb973af2f22f2be12a09.tar.gz
gentoo-2-a4a2b15d2e4e0f880c4dbb973af2f22f2be12a09.tar.bz2
gentoo-2-a4a2b15d2e4e0f880c4dbb973af2f22f2be12a09.zip
bump
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog7
-rw-r--r--dev-python/peewee/peewee-2.3.0.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index 496641d8106f..226d9dfca6d2 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.12 2014/07/13 15:00:17 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.13 2014/08/20 06:20:21 idella4 Exp $
+
+*peewee-2.3.0 (20 Aug 2014)
+
+ 20 Aug 2014; Ian Delaney <idella4@gentoo.org> +peewee-2.3.0.ebuild:
+ bump
*peewee-2.2.5 (13 Jul 2014)
diff --git a/dev-python/peewee/peewee-2.3.0.ebuild b/dev-python/peewee/peewee-2.3.0.ebuild
new file mode 100644
index 000000000000..992720a8ceeb
--- /dev/null
+++ b/dev-python/peewee/peewee-2.3.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.3.0.ebuild,v 1.1 2014/08/20 06:20:21 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="sqlite(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Small python ORM"
+HOMEPAGE="https://github.com/coleifer/peewee/"
+SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/apsw[${PYTHON_USEDEP}]
+ dev-python/psycopg[${PYTHON_USEDEP}]
+ dev-python/django[${PYTHON_USEDEP}]
+ )"
+# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ use examples && local EXAMPLES=( example/. )
+ distutils-r1_python_install_all
+}