summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-05-17 11:38:56 +0000
committerIan Delaney <idella4@gentoo.org>2015-05-17 11:38:56 +0000
commiteca16451e35d44123f39d13679d0a87a6843ed9d (patch)
tree41a74055b17af6818a37d51c5b6c141f04b831b9 /dev-python/peewee
parentDrop ~ppc since its broken like mips. (diff)
downloadgentoo-2-eca16451e35d44123f39d13679d0a87a6843ed9d.tar.gz
gentoo-2-eca16451e35d44123f39d13679d0a87a6843ed9d.tar.bz2
gentoo-2-eca16451e35d44123f39d13679d0a87a6843ed9d.zip
bump; rm deps found to be un-needed in testsuite of -2.5.1, add missed dep for doc build, rm old
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/peewee')
-rw-r--r--dev-python/peewee/ChangeLog10
-rw-r--r--dev-python/peewee/peewee-2.4.7.ebuild42
-rw-r--r--dev-python/peewee/peewee-2.5.0.ebuild42
-rw-r--r--dev-python/peewee/peewee-2.5.1.ebuild10
-rw-r--r--dev-python/peewee/peewee-2.6.0.ebuild (renamed from dev-python/peewee/peewee-2.4.6.ebuild)11
5 files changed, 16 insertions, 99 deletions
diff --git a/dev-python/peewee/ChangeLog b/dev-python/peewee/ChangeLog
index 63763bfc3bcf..7cbc04a2960c 100644
--- a/dev-python/peewee/ChangeLog
+++ b/dev-python/peewee/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/peewee
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.28 2015/04/22 06:59:59 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/ChangeLog,v 1.29 2015/05/17 11:38:56 idella4 Exp $
+
+*peewee-2.6.0 (17 May 2015)
+
+ 17 May 2015; Ian Delaney <idella4@gentoo.org> +peewee-2.6.0.ebuild,
+ -peewee-2.4.6.ebuild, -peewee-2.4.7.ebuild, -peewee-2.5.0.ebuild,
+ peewee-2.5.1.ebuild:
+ bump; rm deps found to be un-needed in testsuite of -2.5.1, add missed dep for
+ doc build, rm old
*peewee-2.5.1 (22 Apr 2015)
diff --git a/dev-python/peewee/peewee-2.4.7.ebuild b/dev-python/peewee/peewee-2.4.7.ebuild
deleted file mode 100644
index a8e383c40859..000000000000
--- a/dev-python/peewee/peewee-2.4.7.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.4.7.ebuild,v 1.1 2015/02/12 07:56:59 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Small python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/apsw[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- )"
-# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/peewee/peewee-2.5.0.ebuild b/dev-python/peewee/peewee-2.5.0.ebuild
deleted file mode 100644
index 010537b2a6f2..000000000000
--- a/dev-python/peewee/peewee-2.5.0.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.5.0.ebuild,v 1.1 2015/03/26 07:00:56 patrick Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_7,3_3,3_4} )
-PYTHON_REQ_USE="sqlite(+)"
-
-inherit distutils-r1
-
-DESCRIPTION="Small python ORM"
-HOMEPAGE="https://github.com/coleifer/peewee/"
-SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-
-RDEPEND=""
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/apsw[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- )"
-# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- "${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
- use examples && local EXAMPLES=( examples/. )
- distutils-r1_python_install_all
-}
diff --git a/dev-python/peewee/peewee-2.5.1.ebuild b/dev-python/peewee/peewee-2.5.1.ebuild
index 0695c0a17c57..fa351f9d7b4a 100644
--- a/dev-python/peewee/peewee-2.5.1.ebuild
+++ b/dev-python/peewee/peewee-2.5.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.5.1.ebuild,v 1.1 2015/04/22 06:59:59 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.5.1.ebuild,v 1.2 2015/05/17 11:38:56 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -15,15 +15,11 @@ SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
+IUSE="doc examples"
RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/apsw[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
DISTUTILS_IN_SOURCE_BUILD=1
diff --git a/dev-python/peewee/peewee-2.4.6.ebuild b/dev-python/peewee/peewee-2.6.0.ebuild
index 41854c2129b6..1a9de55249e9 100644
--- a/dev-python/peewee/peewee-2.4.6.ebuild
+++ b/dev-python/peewee/peewee-2.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.4.6.ebuild,v 1.1 2015/01/26 06:38:27 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/peewee/peewee-2.6.0.ebuild,v 1.1 2015/05/17 11:38:56 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python{2_7,3_3,3_4} )
@@ -15,15 +15,11 @@ SRC_URI="https://github.com/coleifer/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
+IUSE="doc examples"
RDEPEND=""
DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/apsw[${PYTHON_USEDEP}]
- dev-python/psycopg[${PYTHON_USEDEP}]
- dev-python/django[${PYTHON_USEDEP}]
- )"
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
# Req'd to ensure a unique tmp.db for each python impl running the testsuite.
DISTUTILS_IN_SOURCE_BUILD=1
@@ -32,6 +28,7 @@ python_compile_all() {
}
python_test() {
+ # Testsuite run using runtests.py does not require deps listed in previous ebuild
"${PYTHON}" ./runtests.py || die "tests failed under ${EPYTHON}"
}