summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-07-25 02:21:07 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-07-25 02:21:07 +0000
commitbcb3a9e08c2d5e4ac646968f865caba5eb7f6a0b (patch)
tree753fd6b810cd8ce3047efcca1721b77a923d39ae /dev-python/pep8
parentUpdate name in metadata.xml as requested by Denis M. (Phr33d0m) (diff)
downloadgentoo-2-bcb3a9e08c2d5e4ac646968f865caba5eb7f6a0b.tar.gz
gentoo-2-bcb3a9e08c2d5e4ac646968f865caba5eb7f6a0b.tar.bz2
gentoo-2-bcb3a9e08c2d5e4ac646968f865caba5eb7f6a0b.zip
QA: Restore version needed by other packages
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, RepoMan options: --force, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pep8')
-rw-r--r--dev-python/pep8/ChangeLog7
-rw-r--r--dev-python/pep8/pep8-1.3.3.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/dev-python/pep8/ChangeLog b/dev-python/pep8/ChangeLog
index 02822c26869a..83637f6412c8 100644
--- a/dev-python/pep8/ChangeLog
+++ b/dev-python/pep8/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pep8
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/ChangeLog,v 1.17 2013/07/24 11:44:19 djc Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/ChangeLog,v 1.18 2013/07/25 02:21:07 patrick Exp $
+
+*pep8-1.3.3 (25 Jul 2013)
+
+ 25 Jul 2013; Patrick Lauer <patrick@gentoo.org> +pep8-1.3.3.ebuild:
+ QA: Restore version needed by other packages
24 Jul 2013; Dirkjan Ochtman <djc@gentoo.org> -pep8-1.2.ebuild,
-pep8-1.3.3.ebuild, -pep8-1.3.ebuild, -pep8-1.4.1.ebuild, -pep8-1.4.2.ebuild,
diff --git a/dev-python/pep8/pep8-1.3.3.ebuild b/dev-python/pep8/pep8-1.3.3.ebuild
new file mode 100644
index 000000000000..3a175a02a597
--- /dev/null
+++ b/dev-python/pep8/pep8-1.3.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pep8/pep8-1.3.3.ebuild,v 1.5 2013/07/25 02:21:07 patrick Exp $
+
+EAPI=4
+
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils vcs-snapshot
+
+DESCRIPTION="Python style guide checker"
+HOMEPAGE="http://github.com/jcrocholl/pep8 http://pypi.python.org/pypi/pep8"
+SRC_URI="https://github.com/jcrocholl/${PN}/tarball/${PV} -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/setuptools"
+RDEPEND="${DEPEND}"
+
+PYTHON_MODNAME=${PN}.py
+DOCS="CHANGES.txt"
+
+src_test() {
+ test_func() {
+ local test_ok=0
+ PYTHONPATH="${S}" "$(PYTHON)" ${PYTHON_MODNAME} -v --testsuite=testsuite || test_ok=1
+ PYTHONPATH="${S}" "$(PYTHON)" ${PYTHON_MODNAME} --doctest -v || test_ok=1
+ return ${test_ok}
+ }
+ python_execute_function test_func
+}