summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-14 00:08:27 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-14 00:08:27 +0000
commit75157da9042416d6a0b39e9776637134c76c9ac7 (patch)
tree008c805f5a24930f8061dbfc6acc4ec0084bc3d4 /dev-python/polygon
parentMarked -hppa (bug #519772). (diff)
downloadgentoo-2-75157da9042416d6a0b39e9776637134c76c9ac7.tar.gz
gentoo-2-75157da9042416d6a0b39e9776637134c76c9ac7.tar.bz2
gentoo-2-75157da9042416d6a0b39e9776637134c76c9ac7.zip
bump; tidy, rm old
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/polygon')
-rw-r--r--dev-python/polygon/ChangeLog8
-rw-r--r--dev-python/polygon/polygon-2.0.6.ebuild9
-rw-r--r--dev-python/polygon/polygon-3.0.7.ebuild (renamed from dev-python/polygon/polygon-3.0.6.ebuild)25
3 files changed, 28 insertions, 14 deletions
diff --git a/dev-python/polygon/ChangeLog b/dev-python/polygon/ChangeLog
index 8af07b3b2ca1..e7ebc703d261 100644
--- a/dev-python/polygon/ChangeLog
+++ b/dev-python/polygon/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/polygon
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/ChangeLog,v 1.12 2014/07/06 13:18:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/ChangeLog,v 1.13 2014/08/14 00:08:27 idella4 Exp $
+
+*polygon-3.0.7 (13 Aug 2014)
+
+ 13 Aug 2014; Ian Delaney <idella4@gentoo.org> +polygon-3.0.7.ebuild,
+ -polygon-3.0.6.ebuild, polygon-2.0.6.ebuild:
+ bump; tidy, rm old
06 Jul 2014; Michał Górny <mgorny@gentoo.org> polygon-2.0.6.ebuild,
polygon-3.0.6.ebuild:
diff --git a/dev-python/polygon/polygon-2.0.6.ebuild b/dev-python/polygon/polygon-2.0.6.ebuild
index 1a797ea1c1f2..aa78bbba93d4 100644
--- a/dev-python/polygon/polygon-2.0.6.ebuild
+++ b/dev-python/polygon/polygon-2.0.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-2.0.6.ebuild,v 1.2 2014/07/06 13:18:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-2.0.6.ebuild,v 1.3 2014/08/14 00:08:27 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -21,9 +21,6 @@ S=${WORKDIR}/Polygon2-${PV}
DOCS=( HISTORY doc/Polygon.txt )
-src_test() {
- python_test() {
- PYTHONPATH="${BUILD_DIR}/lib" ${EPYTHON} test/Test.py || die
- }
- python_foreach_impl python_test
+python_test() {
+ ${PYTHON} test/Test.py || die "Tests failed"
}
diff --git a/dev-python/polygon/polygon-3.0.6.ebuild b/dev-python/polygon/polygon-3.0.7.ebuild
index 6b63e0d51637..961b0a1c74ba 100644
--- a/dev-python/polygon/polygon-3.0.6.ebuild
+++ b/dev-python/polygon/polygon-3.0.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-3.0.6.ebuild,v 1.2 2014/07/06 13:18:13 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/polygon/polygon-3.0.7.ebuild,v 1.1 2014/08/14 00:08:27 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python3_{2,3,4} )
@@ -13,17 +13,28 @@ SRC_URI="https://www.bitbucket.org/jraedler/${PN}3/downloads/Polygon3-${PV}.zip"
LICENSE="LGPL-2"
SLOT="3"
+IUSE="examples"
KEYWORDS="~amd64 ~ppc ~x86"
DEPEND="app-arch/unzip"
S=${WORKDIR}/Polygon3-${PV}
-DOCS=( HISTORY doc/Polygon.txt )
+DOCS=( doc/{Polygon.txt,Polygon.pdf} )
-src_test() {
- python_test() {
- PYTHONPATH="${BUILD_DIR}/lib" ${EPYTHON} test/Test.py || die
- }
- python_foreach_impl python_test
+python_prepare_all() {
+ if use examples; then
+ mkdir examples || die
+ mv doc/{Examples.py,testpoly.gpf} examples || die
+ fi
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${PYTHON} test/Test.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
}