summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-20 15:59:33 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-12-20 15:59:33 +0000
commit61f613581550b338576f68c4c798186babeca7f3 (patch)
tree514cd5cfc368f857e2866c88eaaedfc2f12e8fa4 /dev-python/psycopg
parentfixed repoman warning (see bug #349096 comment #3) (diff)
downloadgentoo-2-61f613581550b338576f68c4c798186babeca7f3.tar.gz
gentoo-2-61f613581550b338576f68c4c798186babeca7f3.tar.bz2
gentoo-2-61f613581550b338576f68c4c798186babeca7f3.zip
Version bump.
(Portage version: 2.2.0_alpha9_p9/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/psycopg')
-rw-r--r--dev-python/psycopg/ChangeLog8
-rw-r--r--dev-python/psycopg/psycopg-2.3.2.ebuild62
2 files changed, 69 insertions, 1 deletions
diff --git a/dev-python/psycopg/ChangeLog b/dev-python/psycopg/ChangeLog
index 1617e56f3090..5a4f9578b088 100644
--- a/dev-python/psycopg/ChangeLog
+++ b/dev-python/psycopg/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/psycopg
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.111 2010/12/13 20:26:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/ChangeLog,v 1.112 2010/12/20 15:59:33 arfrever Exp $
+
+*psycopg-2.3.2 (20 Dec 2010)
+
+ 20 Dec 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +psycopg-2.3.2.ebuild:
+ Version bump.
*psycopg-2.3.1 (13 Dec 2010)
diff --git a/dev-python/psycopg/psycopg-2.3.2.ebuild b/dev-python/psycopg/psycopg-2.3.2.ebuild
new file mode 100644
index 000000000000..d90e9ce634bd
--- /dev/null
+++ b/dev-python/psycopg/psycopg-2.3.2.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/psycopg/psycopg-2.3.2.ebuild,v 1.1 2010/12/20 15:59:33 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
+
+inherit distutils eutils
+
+MY_P="${PN}2-${PV}"
+
+DESCRIPTION="PostgreSQL database adapter for Python"
+HOMEPAGE="http://initd.org/psycopg/ http://pypi.python.org/pypi/psycopg2"
+SRC_URI="http://initd.org/pub/software/psycopg/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x86-solaris"
+IUSE="debug doc examples mxdatetime"
+
+DEPEND=">=dev-db/postgresql-base-8.1
+ mxdatetime? ( dev-python/egenix-mx-base )"
+RDEPEND="${DEPEND}"
+RESTRICT="test"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="AUTHORS doc/HACKING doc/psycopg2.txt doc/SUCCESS"
+PYTHON_MODNAME="${PN}2"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PN}-2.0.12-setup.py.patch"
+ epatch "${FILESDIR}/${PN}-2.0.9-round-solaris.patch"
+
+ if use debug; then
+ sed -i 's/^\(define=\)/\1PSYCOPG_DEBUG,/' setup.cfg || die "sed failed"
+ fi
+
+ if use mxdatetime; then
+ sed -i 's/\(use_pydatetime=\)1/\10/' setup.cfg || die "sed failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd doc/html > /dev/null
+ docinto html
+ cp -R [a-z]* _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "Installation of examples failed"
+ fi
+}