summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2005-12-21 10:36:13 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2005-12-21 10:36:13 +0000
commitbe4572888f5eb6cb4666f67559ad7548d83ebb2f (patch)
treef4fccd87262838277ef1ac1acd35d1a74c5b0658 /dev-python/pycairo/pycairo-1.0.2.ebuild
parentVersion bumped. Creation of vdr user. New version has i.e. utf8-workaround, s... (diff)
downloadgentoo-2-be4572888f5eb6cb4666f67559ad7548d83ebb2f.tar.gz
gentoo-2-be4572888f5eb6cb4666f67559ad7548d83ebb2f.tar.bz2
gentoo-2-be4572888f5eb6cb4666f67559ad7548d83ebb2f.zip
Version bump and cleanup. Closing bug #104060.
(Portage version: 2.1_pre1)
Diffstat (limited to 'dev-python/pycairo/pycairo-1.0.2.ebuild')
-rw-r--r--dev-python/pycairo/pycairo-1.0.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/pycairo/pycairo-1.0.2.ebuild b/dev-python/pycairo/pycairo-1.0.2.ebuild
new file mode 100644
index 000000000000..4b00fb0ce5ca
--- /dev/null
+++ b/dev-python/pycairo/pycairo-1.0.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycairo/pycairo-1.0.2.ebuild,v 1.1 2005/12/21 10:36:13 lucass Exp $
+
+DESCRIPTION="Python wrapper for cairo vector graphics library"
+HOMEPAGE="http://cairographics.org/pycairo"
+SRC_URI="http://cairographics.org/releases/${P}.tar.gz"
+LICENSE="|| ( LGPL-2.1 MPL-1.1 )"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="gtk numeric svg"
+
+DEPEND=">=dev-lang/python-2.3
+ >=x11-libs/cairo-1.0.2
+ gtk? ( >=dev-python/pygtk-2.2 )
+ svg? ( >=x11-libs/libsvg-cairo-0.1.6 )
+ numeric? ( dev-python/numeric )"
+
+src_compile() {
+ # dev-python/numeric and libsvg-cairo are automatically
+ # detected by the ./configure script, so don't need to force
+ econf $(use_with gtk pygtk)
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "install failed"
+
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ rm ${D}/usr/share/doc/${PF}/examples/Makefile*
+
+ dodoc AUTHORS NOTES README NEWS ChangeLog
+}