summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2013-06-18 08:00:05 +0000
committerTim Harder <radhermit@gentoo.org>2013-06-18 08:00:05 +0000
commitc181bcd73ca9f652e2ade7373f3d5666fc467a9e (patch)
treee24b875e074fcf364d80889d788dac65723f5dc7 /dev-python/pycountry
parentDrop osmosdr from IUSE, add upgrade warning. (diff)
downloadgentoo-2-c181bcd73ca9f652e2ade7373f3d5666fc467a9e.tar.gz
gentoo-2-c181bcd73ca9f652e2ade7373f3d5666fc467a9e.tar.bz2
gentoo-2-c181bcd73ca9f652e2ade7373f3d5666fc467a9e.zip
Version bump.
(Portage version: 2.2.0_alpha180/cvs/Linux x86_64, signed Manifest commit with key 4AB3E85B4F064CA3)
Diffstat (limited to 'dev-python/pycountry')
-rw-r--r--dev-python/pycountry/ChangeLog7
-rw-r--r--dev-python/pycountry/pycountry-0.14.8.ebuild29
2 files changed, 35 insertions, 1 deletions
diff --git a/dev-python/pycountry/ChangeLog b/dev-python/pycountry/ChangeLog
index ebb55ae8739c..5ed4446f68eb 100644
--- a/dev-python/pycountry/ChangeLog
+++ b/dev-python/pycountry/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pycountry
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/ChangeLog,v 1.12 2013/06/16 10:17:59 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/ChangeLog,v 1.13 2013/06/18 08:00:05 radhermit Exp $
+
+*pycountry-0.14.8 (18 Jun 2013)
+
+ 18 Jun 2013; Tim Harder <radhermit@gentoo.org> +pycountry-0.14.8.ebuild:
+ Version bump.
16 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
python will maintain this: http://www.gossamer-
diff --git a/dev-python/pycountry/pycountry-0.14.8.ebuild b/dev-python/pycountry/pycountry-0.14.8.ebuild
new file mode 100644
index 000000000000..684664c480f9
--- /dev/null
+++ b/dev-python/pycountry/pycountry-0.14.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycountry/pycountry-0.14.8.ebuild,v 1.1 2013/06/18 08:00:05 radhermit Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_5,2_6,2_7,3_1,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="ISO country, subdivision, language, currency and script definitions and their translations"
+HOMEPAGE="http://pypi.python.org/pypi/pycountry"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="app-arch/unzip
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+
+DOCS=( HISTORY.txt TODO.txt )
+
+python_test() {
+ # nosetests give coverage output of each run
+ pushd "${BUILD_DIR}"/lib > /dev/null
+ nosetests ${PN}/tests.py || die
+}