summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2009-06-06 15:44:44 +0000
committerMichael Januszewski <spock@gentoo.org>2009-06-06 15:44:44 +0000
commit9efa12866a11eb46d80e9da3a648889a4185acfd (patch)
treed4d4ae92b461cf5f8ac4f229123aa97ed9e42ae5 /dev-python/pycuda/pycuda-0.92.ebuild
parentFix elog message, bug 272899. (diff)
downloadgentoo-2-9efa12866a11eb46d80e9da3a648889a4185acfd.tar.gz
gentoo-2-9efa12866a11eb46d80e9da3a648889a4185acfd.tar.bz2
gentoo-2-9efa12866a11eb46d80e9da3a648889a4185acfd.zip
Initial commit.
(Portage version: 2.1.6.13/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pycuda/pycuda-0.92.ebuild')
-rw-r--r--dev-python/pycuda/pycuda-0.92.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/pycuda/pycuda-0.92.ebuild b/dev-python/pycuda/pycuda-0.92.ebuild
new file mode 100644
index 000000000000..246caa1901a9
--- /dev/null
+++ b/dev-python/pycuda/pycuda-0.92.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pycuda/pycuda-0.92.ebuild,v 1.1 2009/06/06 15:44:44 spock Exp $
+
+EAPI="2"
+
+inherit distutils
+
+DESCRIPTION="Python wrapper for NVIDIA CUDA"
+HOMEPAGE="http://mathema.tician.de/software/pycuda"
+SRC_URI="http://pypi.python.org/packages/source/p/pycuda/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+RDEPEND="dev-python/pytools
+ dev-libs/boost[python]
+ >=dev-util/nvidia-cuda-toolkit-2.0
+ >=dev-python/numpy-1.0.4"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ ./configure.py --cuda-root="${ROOT}opt/cuda" --boost-python-libname=boost_python-mt
+}
+
+src_install()
+{
+ distutils_src_install
+ insinto /usr/share/doc/${PF}
+ if use examples; then
+ doins -r examples || die
+ fi
+}
+
+pkg_postinst()
+{
+ distutils_pkg_postinst
+ if use examples; then
+ elog "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+}