summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-07 16:28:39 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-07 16:28:39 +0000
commit9c72b20edb68c1e695433ecac974ca2a031e5713 (patch)
treec2d595d15459964627e42dbd2fd4b5f69ca4c2ae /dev-python/pyenchant
parentremove now-unneeded games-simulation/openttd mask (diff)
downloadgentoo-2-9c72b20edb68c1e695433ecac974ca2a031e5713.tar.gz
gentoo-2-9c72b20edb68c1e695433ecac974ca2a031e5713.tar.bz2
gentoo-2-9c72b20edb68c1e695433ecac974ca2a031e5713.zip
Fix dependencies. Disable tests when en_US.UTF-8 locale is missing.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyenchant')
-rw-r--r--dev-python/pyenchant/pyenchant-1.6.2.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/pyenchant/pyenchant-1.6.2.ebuild b/dev-python/pyenchant/pyenchant-1.6.2.ebuild
index 4f5c44768582..24c37d8487b4 100644
--- a/dev-python/pyenchant/pyenchant-1.6.2.ebuild
+++ b/dev-python/pyenchant/pyenchant-1.6.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/pyenchant-1.6.2.ebuild,v 1.1 2010/05/29 16:13:54 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyenchant/pyenchant-1.6.2.ebuild,v 1.2 2010/06/07 16:28:39 arfrever Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -17,7 +17,7 @@ SLOT="0"
KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
IUSE=""
-DEPEND=">=app-text/enchant-1.4.0
+DEPEND=">=app-text/enchant-${PV%.*}
dev-python/setuptools"
RDEPEND="${DEPEND}"
@@ -30,3 +30,11 @@ src_prepare() {
# TestInstallEnv tests are broken with Python 3 (enchant.tokenize is wrongly imported as tokenize).
sed -e "s/test_basic/_&/;s/test_UnicodeInstallPath/_&/" -i enchant/tests.py || die "sed failed"
}
+
+src_test() {
+ if [[ -n "$(LC_ALL="en_US.UTF-8" bash -c "" 2>&1)" ]]; then
+ ewarn "Disabling tests due to missing en_US.UTF-8 locale"
+ else
+ distutils_src_test
+ fi
+}