summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-08-20 04:16:27 +0000
committerIan Delaney <idella4@gentoo.org>2014-08-20 04:16:27 +0000
commit3ac4277259ce0465bfcb7f97f86c2c05f295cc85 (patch)
treefd318d97f1508d4eaa381a56d8d55b85c653351b /dev-python/pyfits
parentVersion bump #504748 by teidakankan. (diff)
downloadgentoo-2-3ac4277259ce0465bfcb7f97f86c2c05f295cc85.tar.gz
gentoo-2-3ac4277259ce0465bfcb7f97f86c2c05f295cc85.tar.bz2
gentoo-2-3ac4277259ce0465bfcb7f97f86c2c05f295cc85.zip
add an initial fix to py3 failure in fitscheck, courtesy of Arfrever
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyfits')
-rw-r--r--dev-python/pyfits/ChangeLog5
-rw-r--r--dev-python/pyfits/pyfits-3.3.ebuild6
2 files changed, 9 insertions, 2 deletions
diff --git a/dev-python/pyfits/ChangeLog b/dev-python/pyfits/ChangeLog
index 1cd1c513bb97..a4a9f2dcadea 100644
--- a/dev-python/pyfits/ChangeLog
+++ b/dev-python/pyfits/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-python/pyfits
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfits/ChangeLog,v 1.51 2014/07/22 14:10:55 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfits/ChangeLog,v 1.52 2014/08/20 04:16:27 idella4 Exp $
+
+ 20 Aug 2014; Ian Delaney <idella4@gentoo.org> pyfits-3.3.ebuild:
+ add an initial fix to py3 failure in fitscheck, courtesy of Arfrever
*pyfits-3.3 (22 Jul 2014)
diff --git a/dev-python/pyfits/pyfits-3.3.ebuild b/dev-python/pyfits/pyfits-3.3.ebuild
index e41525ffefac..900aa591ba65 100644
--- a/dev-python/pyfits/pyfits-3.3.ebuild
+++ b/dev-python/pyfits/pyfits-3.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfits/pyfits-3.3.ebuild,v 1.1 2014/07/22 14:10:55 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyfits/pyfits-3.3.ebuild,v 1.2 2014/08/20 04:16:27 idella4 Exp $
EAPI=5
@@ -38,6 +38,10 @@ python_prepare_all() {
sed -i \
-e "s/\(hook_package_dir = \)lib/\1$(get_libdir)/g" \
"${S}"/setup.cfg || die
+
+ # https://github.com/spacetelescope/PyFITS/issues/95
+ sed -e "s/except UserWarning, w/except UserWarning as w/" -i lib/pyfits/scripts/fitscheck.py
+
distutils-r1_python_prepare_all
}