summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-06-04 08:01:09 +0000
committerJustin Lecher <jlec@gentoo.org>2015-06-04 08:01:09 +0000
commitff7d291b103ad0709d54c483dfa0fde6e9074da7 (patch)
tree3be408d5439a90022bf20999fd2c4ee740b2f1e2 /dev-python/pyftpdlib
parentAdd pypi to remote-id in metadata.xml (diff)
downloadgentoo-2-ff7d291b103ad0709d54c483dfa0fde6e9074da7.tar.gz
gentoo-2-ff7d291b103ad0709d54c483dfa0fde6e9074da7.tar.bz2
gentoo-2-ff7d291b103ad0709d54c483dfa0fde6e9074da7.zip
Readd old version, bug #551132
(Portage version: 2.2.20/cvs/Linux x86_64, RepoMan options: --force, signed Manifest commit with key E9402A79B03529A2!)
Diffstat (limited to 'dev-python/pyftpdlib')
-rw-r--r--dev-python/pyftpdlib/ChangeLog7
-rw-r--r--dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild48
2 files changed, 54 insertions, 1 deletions
diff --git a/dev-python/pyftpdlib/ChangeLog b/dev-python/pyftpdlib/ChangeLog
index cf1cd819dd0d..2d4c3a2a9863 100644
--- a/dev-python/pyftpdlib/ChangeLog
+++ b/dev-python/pyftpdlib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyftpdlib
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyftpdlib/ChangeLog,v 1.50 2015/06/03 20:59:31 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyftpdlib/ChangeLog,v 1.51 2015/06/04 08:01:09 jlec Exp $
+
+*pyftpdlib-0.7.0 (04 Jun 2015)
+
+ 04 Jun 2015; Justin Lecher <jlec@gentoo.org> +pyftpdlib-0.7.0.ebuild:
+ Readd old version, bug #551132
03 Jun 2015; Justin Lecher <jlec@gentoo.org> -pyftpdlib-0.7.0.ebuild,
-pyftpdlib-1.0.1-r1.ebuild, -pyftpdlib-1.0.1.ebuild, metadata.xml:
diff --git a/dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild b/dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild
new file mode 100644
index 000000000000..5a0223d94665
--- /dev/null
+++ b/dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyftpdlib/pyftpdlib-0.7.0.ebuild,v 1.15 2015/06/04 08:01:09 jlec Exp $
+
+EAPI="4"
+PYTHON_DEPEND="2"
+PYTHON_USE_WITH="ssl(+)"
+PYTHON_USE_WITH_OPT="ssl"
+SUPPORT_PYTHON_ABIS="1"
+# pypy has no spwd.so
+PYTHON_TESTS_RESTRICTED_ABIS="2.7-pypy-*"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="Python FTP server library"
+HOMEPAGE="http://code.google.com/p/pyftpdlib/ http://pypi.python.org/pypi/pyftpdlib"
+SRC_URI="http://pyftpdlib.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
+IUSE="examples ssl"
+
+DEPEND="ssl? (
+ dev-lang/python:2.7
+ dev-python/pyopenssl
+)"
+RDEPEND="${DEPEND}"
+
+DOCS="CREDITS HISTORY"
+
+src_test() {
+ testing() {
+ for test in test/{test_ftpd.py,test_contrib.py}; do
+ PYTHONPATH="build-${PYTHON_ABI}/lib" "$(PYTHON)" $test || die
+ done
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r demo test
+ fi
+}