summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKacper Kowalik <xarthisius@gentoo.org>2012-05-30 18:11:49 +0000
committerKacper Kowalik <xarthisius@gentoo.org>2012-05-30 18:11:49 +0000
commitb28571afb4b58ef7a095249c7d1ed007fcf08e11 (patch)
treecc1b693ff27299186bf0ebab2058ef8e59c550cc /dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild
parentfix threading support with patch from hasufell (bug #418269) (diff)
downloadgentoo-2-b28571afb4b58ef7a095249c7d1ed007fcf08e11.tar.gz
gentoo-2-b28571afb4b58ef7a095249c7d1ed007fcf08e11.tar.bz2
gentoo-2-b28571afb4b58ef7a095249c7d1ed007fcf08e11.zip
Apply fix for invalid import with python3 by Arfrever Frehtes Taifersar Arahesis <arfrever.fta@gmail.com>. Fixes bug #415593 by Eric Mercier <mercier.eric@gmail.com>. Drop old
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild')
-rw-r--r--dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild b/dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild
new file mode 100644
index 000000000000..3072b48d07b6
--- /dev/null
+++ b/dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.9.2_pre20120101-r1.ebuild,v 1.1 2012/05/30 18:11:49 xarthisius Exp $
+
+EAPI="4"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="*-jython 2.7-pypy-**"
+PYTHON_TESTS_RESTRICTED_ABIS="3.1"
+PYTHON_TESTS_FAILURES_TOLERANT_ABIS="*"
+
+inherit distutils virtualx
+
+DESCRIPTION="Python bindings for SDL multimedia library"
+HOMEPAGE="http://www.pygame.org/"
+if [[ "${PV}" == *_pre* ]]; then
+ SRC_URI="http://people.apache.org/~Arfrever/gentoo/${P}.tar.xz"
+else
+ SRC_URI="http://www.pygame.org/ftp/pygame-${PV}release.tar.gz"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples X"
+
+DEPEND="dev-python/numpy
+ >=media-libs/libsdl-1.2.5[X?]
+ >=media-libs/sdl-image-1.2.2[png,jpeg]
+ >=media-libs/sdl-mixer-1.2.4
+ >=media-libs/sdl-ttf-2.0.6
+ >=media-libs/smpeg-0.4.4-r1"
+RDEPEND="${DEPEND}"
+
+if [[ "${PV}" != *_pre* ]]; then
+ S="${WORKDIR}/${P}release"
+fi
+
+PYTHON_CFLAGS=("2.* + -fno-strict-aliasing")
+
+DOCS="WHATSNEW"
+
+src_configure() {
+ "$(PYTHON -f)" config.py -auto
+
+ if ! use X; then
+ sed -e "s:^scrap :#&:" -i Setup || die "sed failed"
+ fi
+
+ # Disable automagic dependency on PortMidi.
+ sed -e "s:^pypm :#&:" -i Setup || die "sed failed"
+
+ sed -i -e "s/import _camera/from pygame &/g" lib/camera.py || die #415593
+}
+
+src_test() {
+ testing() {
+ PYTHONPATH="$(ls -d build-${PYTHON_ABI}/lib.*)" "$(PYTHON)" run_tests.py
+ }
+ VIRTUALX_COMMAND="python_execute_function" virtualmake testing
+}
+
+src_install() {
+ distutils_src_install
+
+ delete_examples_and_tests() {
+ rm -fr "${ED}$(python_get_sitedir)/pygame/examples"
+ rm -fr "${ED}$(python_get_sitedir)/pygame/tests"
+ }
+ python_execute_function -q delete_examples_and_tests
+
+ if use doc; then
+ dohtml -r docs/*
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/*
+ fi
+}