summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRob Cakebread <pythonhead@gentoo.org>2008-06-26 18:36:15 +0000
committerRob Cakebread <pythonhead@gentoo.org>2008-06-26 18:36:15 +0000
commitbec79fe31f65ff038af9893d5487e0f468f86b33 (patch)
treee7653a19753053c2ca60a9c9ddf17cec6d0b8fbc /dev-python/pygame
parentold (diff)
downloadgentoo-2-bec79fe31f65ff038af9893d5487e0f468f86b33.tar.gz
gentoo-2-bec79fe31f65ff038af9893d5487e0f468f86b33.tar.bz2
gentoo-2-bec79fe31f65ff038af9893d5487e0f468f86b33.zip
Add check for USE='jpeg png' in sdl-image. Closes #227705
(Portage version: 2.1.5.6)
Diffstat (limited to 'dev-python/pygame')
-rw-r--r--dev-python/pygame/ChangeLog6
-rw-r--r--dev-python/pygame/pygame-1.7.1-r1.ebuild20
-rw-r--r--dev-python/pygame/pygame-1.7.1.ebuild22
-rw-r--r--dev-python/pygame/pygame-1.8.0.ebuild7
4 files changed, 40 insertions, 15 deletions
diff --git a/dev-python/pygame/ChangeLog b/dev-python/pygame/ChangeLog
index 9efa3905f99f..4803412b3c4e 100644
--- a/dev-python/pygame/ChangeLog
+++ b/dev-python/pygame/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pygame
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.47 2008/06/20 17:53:36 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/ChangeLog,v 1.48 2008/06/26 18:36:15 pythonhead Exp $
+
+ 26 Jun 2008; Rob Cakebread <pythonhead@gentoo.org> pygame-1.7.1.ebuild,
+ pygame-1.7.1-r1.ebuild, pygame-1.8.0.ebuild:
+ Add check for USE='jpeg png' in sdl-image. Closes #227705
*pygame-1.7.1-r1 (20 Jun 2008)
diff --git a/dev-python/pygame/pygame-1.7.1-r1.ebuild b/dev-python/pygame/pygame-1.7.1-r1.ebuild
index 4e08f65190bf..92aef45d5dd0 100644
--- a/dev-python/pygame/pygame-1.7.1-r1.ebuild
+++ b/dev-python/pygame/pygame-1.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1-r1.ebuild,v 1.1 2008/06/20 17:53:36 coldwind Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1-r1.ebuild,v 1.2 2008/06/26 18:36:15 pythonhead Exp $
inherit eutils distutils
@@ -24,10 +24,18 @@ DEPEND="virtual/python
>=dev-python/numeric-22.0
>=media-libs/smpeg-0.4.4-r1"
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-image png jpeg ; then
+ eerror "Please re-emerge media-libs/sdl-image with the png and jpeg
+ USE-flags set."
+ die "Missing USE-flag for media-libs/sdl-image"
+ fi
+}
+
src_unpack() {
unpack ${A}
# Search correct libdir for existing sdl libs
- sed -i -e "s:/lib:/$(get_libdir):" ${S}/config_unix.py || die
+ sed -i -e "s:/lib:/$(get_libdir):" "${S}"/config_unix.py || die
cd "${S}"
epatch "${FILESDIR}"/${P}-python2.5.patch
}
@@ -38,9 +46,9 @@ src_install() {
if use doc; then
dohtml -r docs/*
- insinto /usr/share/doc/${PF}/examples
- doins ${S}/examples/*
- insinto /usr/share/doc/${PF}/examples/data
- doins ${S}/examples/data/*
+ insinto /usr/share/doc/"${PF}"/examples
+ doins "${S}"/examples/*
+ insinto /usr/share/doc/"${PF}"/examples/data
+ doins "${S}"/examples/data/*
fi
}
diff --git a/dev-python/pygame/pygame-1.7.1.ebuild b/dev-python/pygame/pygame-1.7.1.ebuild
index bb4dc7f3d37c..e6e9dd2aed8b 100644
--- a/dev-python/pygame/pygame-1.7.1.ebuild
+++ b/dev-python/pygame/pygame-1.7.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1.ebuild,v 1.12 2007/08/07 07:44:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.7.1.ebuild,v 1.13 2008/06/26 18:36:15 pythonhead Exp $
inherit distutils
@@ -24,10 +24,18 @@ DEPEND="virtual/python
>=dev-python/numeric-22.0
>=media-libs/smpeg-0.4.4-r1"
+pkg_setup() {
+ if ! built_with_use media-libs/sdl-image png jpeg ; then
+ eerror "Please re-emerge media-libs/sdl-image with the png and jpeg
+ USE-flags set."
+ die "Missing USE-flag for media-libs/sdl-image"
+ fi
+}
+
src_unpack() {
unpack ${A}
# Search correct libdir for existing sdl libs
- sed -i -e "s:/lib:/$(get_libdir):" ${S}/config_unix.py || die
+ sed -i -e "s:/lib:/$(get_libdir):" "${S}"/config_unix.py || die
}
src_install() {
@@ -36,9 +44,9 @@ src_install() {
if use doc; then
dohtml -r docs/*
- insinto /usr/share/doc/${PF}/examples
- doins ${S}/examples/*
- insinto /usr/share/doc/${PF}/examples/data
- doins ${S}/examples/data/*
+ insinto /usr/share/doc/"${PF}"/examples
+ doins "${S}"/examples/*
+ insinto /usr/share/doc/"${PF}"/examples/data
+ doins "${S}"/examples/data/*
fi
}
diff --git a/dev-python/pygame/pygame-1.8.0.ebuild b/dev-python/pygame/pygame-1.8.0.ebuild
index f9d76b84e4a0..715fa05bfd83 100644
--- a/dev-python/pygame/pygame-1.8.0.ebuild
+++ b/dev-python/pygame/pygame-1.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.8.0.ebuild,v 1.1 2008/04/09 04:44:35 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygame/pygame-1.8.0.ebuild,v 1.2 2008/06/26 18:36:15 pythonhead Exp $
inherit distutils multilib eutils
@@ -29,6 +29,11 @@ pkg_setup() {
eerror "Please re-emerge media-libs/libsdl with the X USE-flag set."
die "Missing USE-flag for media-libs/libsdl"
fi
+ if ! built_with_use media-libs/sdl-image png jpeg ; then
+ eerror "Please re-emerge media-libs/sdl-image with the png and jpeg
+ USE-flags set."
+ die "Missing USE-flag for media-libs/sdl-image"
+ fi
}
src_compile() {