summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2007-10-05 20:12:09 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2007-10-05 20:12:09 +0000
commit114b780aadbcf71c07da58c52a72f8e733c8318f (patch)
tree3e2095515f9f4fe85382b5abeffcbdcf25c735ea /dev-python/pygsl
parentalpha/sparc stable wrt #192247 (diff)
downloadgentoo-2-114b780aadbcf71c07da58c52a72f8e733c8318f.tar.gz
gentoo-2-114b780aadbcf71c07da58c52a72f8e733c8318f.tar.bz2
gentoo-2-114b780aadbcf71c07da58c52a72f8e733c8318f.zip
added pygsl-0.9.0 which works with gsl-1.10, fixed deps on pygsl-0.9.1 which does not work with gsl-1.10
(Portage version: 2.1.3.9)
Diffstat (limited to 'dev-python/pygsl')
-rw-r--r--dev-python/pygsl/ChangeLog9
-rw-r--r--dev-python/pygsl/files/digest-pygsl-0.9.03
-rw-r--r--dev-python/pygsl/pygsl-0.9.0.ebuild30
-rw-r--r--dev-python/pygsl/pygsl-0.9.1.ebuild6
4 files changed, 44 insertions, 4 deletions
diff --git a/dev-python/pygsl/ChangeLog b/dev-python/pygsl/ChangeLog
index 5a27cd90e6fc..b31ab647b508 100644
--- a/dev-python/pygsl/ChangeLog
+++ b/dev-python/pygsl/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pygsl
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/ChangeLog,v 1.1 2007/08/16 12:52:12 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/ChangeLog,v 1.2 2007/10/05 20:12:08 bicatali Exp $
+
+*pygsl-0.9.0 (05 Oct 2007)
+
+ 05 Oct 2007; Sébastien Fabbro <bicatali@gentoo.org> +pygsl-0.9.0.ebuild,
+ pygsl-0.9.1.ebuild:
+ added pygsl-0.9.0 which works with gsl-1.10, fixed deps on pygsl-0.9.1 which
+ does not work with gsl-1.10
*pygsl-0.9.1 (16 Aug 2007)
diff --git a/dev-python/pygsl/files/digest-pygsl-0.9.0 b/dev-python/pygsl/files/digest-pygsl-0.9.0
new file mode 100644
index 000000000000..c334ef9e096a
--- /dev/null
+++ b/dev-python/pygsl/files/digest-pygsl-0.9.0
@@ -0,0 +1,3 @@
+MD5 c69c3deed25525f153f2f03942e99040 pygsl-0.9.0.tar.gz 514471
+RMD160 50c29f95031fa1aab4d64b3619c78eaef66a304f pygsl-0.9.0.tar.gz 514471
+SHA256 90fb5c167178144ed0ac1c9b3f6923719d68bbe8ca262cd27d310f94eb10607c pygsl-0.9.0.tar.gz 514471
diff --git a/dev-python/pygsl/pygsl-0.9.0.ebuild b/dev-python/pygsl/pygsl-0.9.0.ebuild
new file mode 100644
index 000000000000..2bb5da87dc62
--- /dev/null
+++ b/dev-python/pygsl/pygsl-0.9.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/pygsl-0.9.0.ebuild,v 1.1 2007/10/05 20:12:08 bicatali Exp $
+
+inherit distutils
+
+DESCRIPTION="A Python interface for the GNU scientific library (gsl)."
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND=">=sci-libs/gsl-1.8
+ >=dev-python/numpy-1.0"
+
+src_test() {
+ cd "${S}/tests"
+ PYTHONPATH=$(ls -d ../build/lib*) "${python}" run_test.py || die "tests failed"
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "install examples failed"
+ fi
+}
diff --git a/dev-python/pygsl/pygsl-0.9.1.ebuild b/dev-python/pygsl/pygsl-0.9.1.ebuild
index 426f7ed12364..b988174b1f4b 100644
--- a/dev-python/pygsl/pygsl-0.9.1.ebuild
+++ b/dev-python/pygsl/pygsl-0.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/pygsl-0.9.1.ebuild,v 1.2 2007/08/17 00:34:29 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/pygsl-0.9.1.ebuild,v 1.3 2007/10/05 20:12:08 bicatali Exp $
inherit distutils
@@ -13,7 +13,7 @@ LICENSE="GPL-2"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-DEPEND=">=sci-libs/gsl-1.8
+DEPEND="<sci-libs/gsl-1.10
>=dev-python/numpy-1.0"
src_test() {
@@ -25,6 +25,6 @@ src_install() {
distutils_src_install
if use examples; then
insinto /usr/share/doc/${PF}
- doins -r examples
+ doins -r examples || die "install examples failed"
fi
}