summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2010-04-28 04:12:32 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2010-04-28 04:12:32 +0000
commit58756286e45806ad9a0bd2aedc3c60492c3ebf61 (patch)
treeb090aa01e4cbbe0a1071745a10c1e0e6947d601d /dev-python/pygsl
parentVersion bump (diff)
downloadgentoo-2-58756286e45806ad9a0bd2aedc3c60492c3ebf61.tar.gz
gentoo-2-58756286e45806ad9a0bd2aedc3c60492c3ebf61.tar.bz2
gentoo-2-58756286e45806ad9a0bd2aedc3c60492c3ebf61.zip
Version bump
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygsl')
-rw-r--r--dev-python/pygsl/ChangeLog7
-rw-r--r--dev-python/pygsl/pygsl-0.9.5.ebuild37
2 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/pygsl/ChangeLog b/dev-python/pygsl/ChangeLog
index 3c0338a23daa..f6c269e779ed 100644
--- a/dev-python/pygsl/ChangeLog
+++ b/dev-python/pygsl/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pygsl
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/ChangeLog,v 1.14 2010/04/26 20:19:43 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/ChangeLog,v 1.15 2010/04/28 04:12:32 bicatali Exp $
+
+*pygsl-0.9.5 (28 Apr 2010)
+
+ 28 Apr 2010; Sébastien Fabbro <bicatali@gentoo.org> +pygsl-0.9.5.ebuild:
+ Version bump
26 Apr 2010; Markus Meier <maekke@gentoo.org> pygsl-0.9.4.ebuild:
amd64 stable, bug #300267
diff --git a/dev-python/pygsl/pygsl-0.9.5.ebuild b/dev-python/pygsl/pygsl-0.9.5.ebuild
new file mode 100644
index 000000000000..28e8918bc181
--- /dev/null
+++ b/dev-python/pygsl/pygsl-0.9.5.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygsl/pygsl-0.9.5.ebuild,v 1.1 2010/04/28 04:12:32 bicatali Exp $
+
+EAPI=2
+SUPPORT_PYTHON_ABIS="1"
+inherit distutils
+
+DESCRIPTION="A Python interface for the GNU scientific library (gsl)."
+HOMEPAGE="http://pygsl.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="examples"
+
+DEPEND="sci-libs/gsl
+ dev-python/numpy"
+RDEPEND="${DEPEND}"
+RESTRICT_PYTHON_ABIS="3.*"
+
+src_test() {
+ testing() {
+ cd "${S}/tests"
+ PYTHONPATH=$(ls -d ../build-${PYTHON_ABI}/lib*) "$(PYTHON)" run_test.py
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples || die "install examples failed"
+ fi
+}