summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-27 18:45:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-08-27 18:45:47 +0000
commit48f137c2a0602551f5d4055d27526a3747d8e79b (patch)
treecc96717fdc76b322e939e521193b0f059fe86f0a /dev-python/pygtk
parentVersion bump. (diff)
downloadgentoo-2-48f137c2a0602551f5d4055d27526a3747d8e79b.tar.gz
gentoo-2-48f137c2a0602551f5d4055d27526a3747d8e79b.tar.bz2
gentoo-2-48f137c2a0602551f5d4055d27526a3747d8e79b.zip
Set SUPPORT_PYTHON_ABIS (bug #282857).
(Portage version: 14166-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog8
-rw-r--r--dev-python/pygtk/pygtk-2.14.1-r2.ebuild117
2 files changed, 124 insertions, 1 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index 21595366a008..e4d441623548 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygtk
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.219 2009/08/19 16:34:47 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.220 2009/08/27 18:45:47 arfrever Exp $
+
+*pygtk-2.14.1-r2 (27 Aug 2009)
+
+ 27 Aug 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +pygtk-2.14.1-r2.ebuild:
+ Set SUPPORT_PYTHON_ABIS (bug #282857).
19 Aug 2009; Jeroen Roovers <jer@gentoo.org> pygtk-2.14.1-r1.ebuild:
Stable for HPPA (bug #279391).
diff --git a/dev-python/pygtk/pygtk-2.14.1-r2.ebuild b/dev-python/pygtk/pygtk-2.14.1-r2.ebuild
new file mode 100644
index 000000000000..1b3920846d13
--- /dev/null
+++ b/dev-python/pygtk/pygtk-2.14.1-r2.ebuild
@@ -0,0 +1,117 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.14.1-r2.ebuild,v 1.1 2009/08/27 18:45:47 arfrever Exp $
+
+EAPI="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx
+
+DESCRIPTION="GTK+2 bindings for Python"
+HOMEPAGE="http://www.pygtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc examples"
+
+RDEPEND=">=dev-libs/glib-2.8.0
+ >=x11-libs/pango-1.16.0
+ >=dev-libs/atk-1.12.0
+ >=x11-libs/gtk+-2.13.6
+ >=gnome-base/libglade-2.5.0
+ >=dev-lang/python-2.4.4-r5
+ >=dev-python/pycairo-1.0.2
+ >=dev-python/pygobject-2.15.3
+ dev-python/numpy"
+
+DEPEND="${RDEPEND}
+ doc? (
+ dev-libs/libxslt
+ >=app-text/docbook-xsl-stylesheets-1.70.1 )
+ >=dev-util/pkgconfig-0.9"
+
+RESTRICT_PYTHON_ABIS="3*"
+
+src_prepare() {
+ # Fix declaration of codegen in .pc
+ epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
+
+ # Fix test failurs due to ltihooks
+ # gentoo bug #268315, upstream bug #565593
+ epatch "${FILESDIR}/${P}-ltihooks.patch"
+
+ # Switch to numpy, bug #185692
+ epatch "${FILESDIR}/${P}-numpy.patch"
+ epatch "${FILESDIR}/${P}-fix-numpy-warning.patch"
+
+ # Fix bug with GtkToggleButton and gtk+-2.16, bug #275449
+ epatch "${FILESDIR}/${P}-gtktoggle.patch"
+
+ # disable pyc compiling
+ mv "${S}"/py-compile "${S}"/py-compile.orig
+ ln -s $(type -P true) "${S}"/py-compile
+
+ AT_M4DIR="m4" eautoreconf
+
+ python_copy_sources
+}
+
+src_configure() {
+ configuration() {
+ use hppa && append-flags -ffunction-sections
+ econf $(use_enable doc docs) --enable-thread
+ }
+ python_execute_function -s configuration
+}
+
+src_compile() {
+ python_execute_function -d -s
+}
+
+src_install() {
+ python_execute_function -d -s
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
+
+ if use examples; then
+ rm examples/Makefile*
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}
+
+src_test() {
+ unset DBUS_SESSION_BUS_ADDRESS
+
+ testing() {
+ if has ${PYTHON_ABI} 2.4 2.5; then
+ einfo "Skipping tests with Python ${PYTHON_ABI}. dev-python/pycairo supports only Python >=2.6."
+ return 0
+ fi
+
+ cd tests
+ Xemake check-local
+ }
+ python_execute_function -s testing
+}
+
+pkg_postinst() {
+ python_need_rebuild
+ python_mod_optimize gtk-2.0
+
+ create_symlinks() {
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
+ }
+ python_execute_function create_symlinks
+}
+
+pkg_postrm() {
+ python_mod_cleanup gtk-2.0
+
+ create_symlinks() {
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
+ alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
+ }
+ python_execute_function create_symlinks
+}