summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-11-21 23:01:49 +0000
committerPacho Ramos <pacho@gentoo.org>2011-11-21 23:01:49 +0000
commite08ba312213e6bcdbae6c93c3d840f16a0730bd9 (patch)
tree451026940431504fe513975427c0100ca9390f8f /dev-python/pygtk
parentMask gnome-python metas for removal (diff)
downloadgentoo-2-e08ba312213e6bcdbae6c93c3d840f16a0730bd9.tar.gz
gentoo-2-e08ba312213e6bcdbae6c93c3d840f16a0730bd9.tar.bz2
gentoo-2-e08ba312213e6bcdbae6c93c3d840f16a0730bd9.zip
Call gnome2_environment_reset to let tests pass without permissions problems (bug #245103), note that it will only work if you have, at least, glib-2.30.1-r1. Drop old.
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygtk')
-rw-r--r--dev-python/pygtk/ChangeLog10
-rw-r--r--dev-python/pygtk/files/pygtk-2.22.0-disable-broken-tests.patch50
-rw-r--r--dev-python/pygtk/files/pygtk-2.22.0-wakeupfd-fix.patch26
-rw-r--r--dev-python/pygtk/pygtk-2.22.0-r1.ebuild103
-rw-r--r--dev-python/pygtk/pygtk-2.23.2.ebuild97
-rw-r--r--dev-python/pygtk/pygtk-2.24.0-r2.ebuild16
6 files changed, 19 insertions, 283 deletions
diff --git a/dev-python/pygtk/ChangeLog b/dev-python/pygtk/ChangeLog
index cda8b6519d81..be0607d3b835 100644
--- a/dev-python/pygtk/ChangeLog
+++ b/dev-python/pygtk/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/pygtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.263 2011/11/10 22:34:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/ChangeLog,v 1.264 2011/11/21 23:01:47 pacho Exp $
+
+ 21 Nov 2011; Pacho Ramos <pacho@gentoo.org>
+ -files/pygtk-2.22.0-disable-broken-tests.patch,
+ -files/pygtk-2.22.0-wakeupfd-fix.patch, -pygtk-2.22.0-r1.ebuild,
+ -pygtk-2.23.2.ebuild, pygtk-2.24.0-r2.ebuild:
+ Call gnome2_environment_reset to let tests pass without permissions problems
+ (bug #245103), note that it will only work if you have, at least,
+ glib-2.30.1-r1. Drop old.
*pygtk-2.24.0-r2 (10 Nov 2011)
diff --git a/dev-python/pygtk/files/pygtk-2.22.0-disable-broken-tests.patch b/dev-python/pygtk/files/pygtk-2.22.0-disable-broken-tests.patch
deleted file mode 100644
index cc1998561f7a..000000000000
--- a/dev-python/pygtk/files/pygtk-2.22.0-disable-broken-tests.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Disable tests using PObject that appears to be broken.
-Upstream unresponsive and application seem to be working still.
-
-Gentoo: #347183
-Gnome: #636589
---- a/tests/test_enum.py 2010-08-07 07:23:44.000000000 +0200
-+++ b/tests/test_enum.py 2011-01-19 18:43:58.946771795 +0100
-@@ -6,13 +6,6 @@
- from common import gobject, atk, gtk, gdk
-
-
--class PObject(gobject.GObject):
-- enum = gobject.property(type=gtk.WindowType, default=gtk.WINDOW_TOPLEVEL)
-- enum2 = gobject.property(type=gtk.WindowType, default=int(gtk.WINDOW_TOPLEVEL))
-- flags = gobject.property(type=gtk.AttachOptions, default=gtk.EXPAND)
-- flags2 = gobject.property(type=gtk.AttachOptions, default=int(gtk.EXPAND))
--
--
- class EnumTest(unittest.TestCase):
- def testEnums(self):
- self.failUnless(issubclass(gobject.GEnum, int))
-@@ -90,14 +83,6 @@
- self.failUnless('7' in repr(val))
- self.failUnless('GtkIconSize' in repr(val))
-
-- def testEnumProperty(self):
-- default = PObject.props.enum.default_value
-- self.failUnless(isinstance(default, gtk.WindowType))
-- self.assertEqual(default, gtk.WINDOW_TOPLEVEL)
-- default = PObject.props.enum2.default_value
-- self.failUnless(isinstance(default, gtk.WindowType))
-- self.assertEqual(default, gtk.WINDOW_TOPLEVEL)
--
- def testPickling(self):
- values = [getattr(gtk, name) for name in dir(gtk)
- if isinstance(getattr(gtk, name), gobject.gobject.GEnum)]
-@@ -222,13 +207,5 @@
- self.failUnless(flag <= 2)
- self.failUnless(flag <= 10)
-
-- def testFlagsProperty(self):
-- default = PObject.props.flags.default_value
-- self.failUnless(isinstance(default, gtk.AttachOptions))
-- self.assertEqual(default, gtk.EXPAND)
-- default = PObject.props.flags2.default_value
-- self.failUnless(isinstance(default, gtk.AttachOptions))
-- self.assertEqual(default, gtk.EXPAND)
--
- if __name__ == '__main__':
- unittest.main()
diff --git a/dev-python/pygtk/files/pygtk-2.22.0-wakeupfd-fix.patch b/dev-python/pygtk/files/pygtk-2.22.0-wakeupfd-fix.patch
deleted file mode 100644
index 3e5cd4553185..000000000000
--- a/dev-python/pygtk/files/pygtk-2.22.0-wakeupfd-fix.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-From 4cbd3c031289775f365c247f949d91facac4ba82 Mon Sep 17 00:00:00 2001
-From: Dieter Verfaillie <dieterv@optionexplicit.be>
-Date: Thu, 03 Feb 2011 12:44:10 +0000
-Subject: Fix pygtk_main_watch_check, copied from pygobject/glib/pygmainloop.c:pyg_signal_watch_check.
-
-Fixes bug 640738 and 638780.
----
-diff --git a/gtk/gtk.override b/gtk/gtk.override
-index 75018f4..94309a6 100644
---- a/gtk/gtk.override
-+++ b/gtk/gtk.override
-@@ -1151,9 +1151,10 @@ pygtk_main_watch_check(GSource *source)
- #ifdef HAVE_PYSIGNAL_SETWAKEUPFD
- PySignalWatchSource *real_source = (PySignalWatchSource *)source;
- GPollFD *poll_fd = &real_source->fd;
-- int data_size = 0;
-+ unsigned char dummy;
-+ gssize ret;
- if (poll_fd->revents & G_IO_IN)
-- data_size = read(poll_fd->fd, 0, 1);
-+ ret = read(poll_fd->fd, &dummy, 1);
- #endif
-
- state = pyg_gil_state_ensure();
---
-cgit v0.8.3.1
diff --git a/dev-python/pygtk/pygtk-2.22.0-r1.ebuild b/dev-python/pygtk/pygtk-2.22.0-r1.ebuild
deleted file mode 100644
index 180fe2caa0a1..000000000000
--- a/dev-python/pygtk/pygtk-2.22.0-r1.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.22.0-r1.ebuild,v 1.10 2011/03/22 19:03:56 ranger Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-# dev-python/pycairo does not support Python 2.4 / 2.5.
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx
-
-DESCRIPTION="GTK+2 bindings for Python"
-HOMEPAGE="http://www.pygtk.org/"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples"
-
-RDEPEND=">=dev-libs/glib-2.8:2
- >=x11-libs/pango-1.16
- >=dev-libs/atk-1.12
- >=x11-libs/gtk+-2.22:2
- >=gnome-base/libglade-2.5:2.0
- >=dev-python/pycairo-1.0.2
- >=dev-python/pygobject-2.21.3:2
- dev-python/numpy"
-
-DEPEND="${RDEPEND}
- doc? (
- dev-libs/libxslt
- >=app-text/docbook-xsl-stylesheets-1.70.1 )
- >=dev-util/pkgconfig-0.9"
-
-src_prepare() {
- # Fix declaration of codegen in .pc
- epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
-
- # Broken test, upstream bug #636589
- epatch "${FILESDIR}/${PN}-2.22.0-disable-broken-tests.patch"
-
- # Fix 100% CPU load when apps receive SIGCHLD, bug #353599
- epatch "${FILESDIR}/${PN}-2.22.0-wakeupfd-fix.patch"
-
- # Disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
-
- AT_M4DIR="m4" eautoreconf
-
- python_copy_sources
-}
-
-src_configure() {
- use hppa && append-flags -ffunction-sections
- python_src_configure $(use_enable doc docs) --enable-thread
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
-
- testing() {
- cd tests
- export XDG_CONFIG_HOME="${T}/$(PYTHON --ABI)"
- Xemake check-local
- }
- python_execute_function -s testing
-}
-
-src_install() {
- python_src_install
- python_clean_installation_image
- dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO || die
-
- if use examples; then
- rm examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize gtk-2.0
-
- create_symlinks() {
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
- }
- python_execute_function create_symlinks
-}
-
-pkg_postrm() {
- python_mod_cleanup gtk-2.0
-
- create_symlinks() {
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
- }
- python_execute_function create_symlinks
-}
diff --git a/dev-python/pygtk/pygtk-2.23.2.ebuild b/dev-python/pygtk/pygtk-2.23.2.ebuild
deleted file mode 100644
index 132f20889da4..000000000000
--- a/dev-python/pygtk/pygtk-2.23.2.ebuild
+++ /dev/null
@@ -1,97 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.23.2.ebuild,v 1.1 2011/03/28 22:16:32 eva Exp $
-
-EAPI="3"
-GCONF_DEBUG="no"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-# dev-python/pycairo does not support Python 2.4 / 2.5.
-RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
-PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-
-inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx
-
-DESCRIPTION="GTK+2 bindings for Python"
-HOMEPAGE="http://www.pygtk.org/"
-
-LICENSE="LGPL-2.1"
-SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-interix ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples"
-
-RDEPEND=">=dev-libs/glib-2.8:2
- >=x11-libs/pango-1.16
- >=dev-libs/atk-1.12
- >=x11-libs/gtk+-2.24:2
- >=gnome-base/libglade-2.5:2.0
- >=dev-python/pycairo-1.0.2
- >=dev-python/pygobject-2.21.3:2
- dev-python/numpy
-"
-DEPEND="${RDEPEND}
- doc? (
- dev-libs/libxslt
- >=app-text/docbook-xsl-stylesheets-1.70.1 )
- >=dev-util/pkgconfig-0.9"
-
-src_prepare() {
- # Fix declaration of codegen in .pc
- epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
-
- # Disable pyc compiling
- mv "${S}"/py-compile "${S}"/py-compile.orig
- ln -s $(type -P true) "${S}"/py-compile
-
- AT_M4DIR="m4" eautoreconf
-
- python_copy_sources
-}
-
-src_configure() {
- use hppa && append-flags -ffunction-sections
- python_src_configure $(use_enable doc docs) --enable-thread
-}
-
-src_test() {
- unset DBUS_SESSION_BUS_ADDRESS
-
- testing() {
- cd tests
- export XDG_CONFIG_HOME="${T}/$(PYTHON --ABI)"
- Xemake check-local
- }
- python_execute_function -s testing
-}
-
-src_install() {
- python_src_install
- python_clean_installation_image
- dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO || die
-
- if use examples; then
- rm examples/Makefile*
- insinto /usr/share/doc/${PF}
- doins -r examples || die
- fi
-}
-
-pkg_postinst() {
- python_mod_optimize gtk-2.0
-
- create_symlinks() {
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
- }
- python_execute_function create_symlinks
-}
-
-pkg_postrm() {
- python_mod_cleanup gtk-2.0
-
- create_symlinks() {
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.py pygtk.py-[0-9].[0-9]
- alternatives_auto_makesym $(python_get_sitedir)/pygtk.pth pygtk.pth-[0-9].[0-9]
- }
- python_execute_function create_symlinks
-}
diff --git a/dev-python/pygtk/pygtk-2.24.0-r2.ebuild b/dev-python/pygtk/pygtk-2.24.0-r2.ebuild
index c12edd38bc36..f5a2742dc9d1 100644
--- a/dev-python/pygtk/pygtk-2.24.0-r2.ebuild
+++ b/dev-python/pygtk/pygtk-2.24.0-r2.ebuild
@@ -1,16 +1,18 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r2.ebuild,v 1.1 2011/11/10 22:34:48 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtk/pygtk-2.24.0-r2.ebuild,v 1.2 2011/11/21 23:01:47 pacho Exp $
-EAPI="3"
+EAPI="4"
GCONF_DEBUG="no"
+GNOME_TARBALL_SUFFIX="bz2"
+
PYTHON_DEPEND="2:2.6"
SUPPORT_PYTHON_ABIS="1"
# dev-python/pycairo does not support Python 2.4 / 2.5.
RESTRICT_PYTHON_ABIS="2.4 2.5 3.* *-jython"
PYTHON_EXPORT_PHASE_FUNCTIONS="1"
-inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx
+inherit alternatives autotools eutils flag-o-matic gnome.org python virtualx gnome2-utils
DESCRIPTION="GTK+2 bindings for Python"
HOMEPAGE="http://www.pygtk.org/"
@@ -36,6 +38,9 @@ DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.9"
src_prepare() {
+ # Let tests pass without permissions problems, bug #245103
+ gnome2_environment_reset
+
# Fix declaration of codegen in .pc
epatch "${FILESDIR}/${PN}-2.13.0-fix-codegen-location.patch"
epatch "${FILESDIR}/${PN}-2.14.1-libdir-pc.patch"
@@ -62,7 +67,6 @@ src_test() {
testing() {
cd tests
- export XDG_CONFIG_HOME="${T}/$(PYTHON --ABI)"
Xemake check-local
}
python_execute_function -s testing
@@ -71,12 +75,12 @@ src_test() {
src_install() {
python_src_install
python_clean_installation_image
- dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO || die
+ dodoc AUTHORS ChangeLog INSTALL MAPPING NEWS README THREADS TODO
if use examples; then
rm examples/Makefile*
insinto /usr/share/doc/${PF}
- doins -r examples || die
+ doins -r examples
fi
}