summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-12 20:43:43 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-09-12 20:43:43 +0000
commitd42c8db3bf29a493dcd58d0cc760148a54489f92 (patch)
tree0905518dbfe566aca8faa50d93c6630c4a289bc3 /dev-python/pygtkhelpers
parenthonor LDFLAGS (bug #336948); honor CC; tidy install image (diff)
downloadgentoo-2-d42c8db3bf29a493dcd58d0cc760148a54489f92.tar.gz
gentoo-2-d42c8db3bf29a493dcd58d0cc760148a54489f92.tar.bz2
gentoo-2-d42c8db3bf29a493dcd58d0cc760148a54489f92.zip
Version bump.
(Portage version: 2.2_rc80/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pygtkhelpers')
-rw-r--r--dev-python/pygtkhelpers/ChangeLog8
-rw-r--r--dev-python/pygtkhelpers/pygtkhelpers-0.4.2.ebuild55
2 files changed, 62 insertions, 1 deletions
diff --git a/dev-python/pygtkhelpers/ChangeLog b/dev-python/pygtkhelpers/ChangeLog
index a09eb1502efc..5fae621bc158 100644
--- a/dev-python/pygtkhelpers/ChangeLog
+++ b/dev-python/pygtkhelpers/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pygtkhelpers
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkhelpers/ChangeLog,v 1.1 2010/06/23 23:29:26 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkhelpers/ChangeLog,v 1.2 2010/09/12 20:43:43 arfrever Exp $
+
+*pygtkhelpers-0.4.2 (12 Sep 2010)
+
+ 12 Sep 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pygtkhelpers-0.4.1.ebuild, +pygtkhelpers-0.4.2.ebuild:
+ Version bump.
*pygtkhelpers-0.4.1 (23 Jun 2010)
diff --git a/dev-python/pygtkhelpers/pygtkhelpers-0.4.2.ebuild b/dev-python/pygtkhelpers/pygtkhelpers-0.4.2.ebuild
new file mode 100644
index 000000000000..67a91f486d74
--- /dev/null
+++ b/dev-python/pygtkhelpers/pygtkhelpers-0.4.2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pygtkhelpers/pygtkhelpers-0.4.2.ebuild,v 1.1 2010/09/12 20:43:43 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils
+
+DESCRIPTION="PyGTKHelpers is a library to assist the building of PyGTK applications"
+HOMEPAGE="http://packages.python.org/pygtkhelpers/ http://pypi.python.org/pypi/pygtkhelpers"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="doc examples"
+
+DEPEND="dev-python/setuptools
+ doc? ( dev-python/sphinx )"
+RDEPEND=""
+
+src_prepare() {
+ distutils_src_prepare
+
+ # docs/_static/scope.jpg does not exist.
+ sed -e "s/^\(html_logo =.*\)/#\1/" -i docs/conf.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ einfo "Generation of documentation"
+ "$(PYTHON -f)" setup.py build_sphinx || die "Generation of documentation failed"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+
+ if use doc; then
+ pushd build/sphinx/html > /dev/null
+ docinto html
+ cp -R [a-z]* _images _static "${ED}usr/share/doc/${PF}/html" || die "Installation of documentation failed"
+ popd > /dev/null
+ fi
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins -r examples/* || die "Installation of examples failed"
+ fi
+}