summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-02-18 01:46:57 +0000
committerIan Delaney <idella4@gentoo.org>2015-02-18 01:46:57 +0000
commitf44ffb71e096c957558c147a8e39ae81fb7c71db (patch)
treea72013605726d3083ae068de2e88e8fae301d9fc /dev-python/pyifp
parentsupport >=vdr-2.1.10, fix some deprecated warnings in new vdr major release (diff)
downloadgentoo-2-f44ffb71e096c957558c147a8e39ae81fb7c71db.tar.gz
gentoo-2-f44ffb71e096c957558c147a8e39ae81fb7c71db.tar.bz2
gentoo-2-f44ffb71e096c957558c147a8e39ae81fb7c71db.zip
revbump; convert -> distutils-r1, rm old
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyifp')
-rw-r--r--dev-python/pyifp/ChangeLog11
-rw-r--r--dev-python/pyifp/pyifp-0.2.2-r1.ebuild29
-rw-r--r--dev-python/pyifp/pyifp-0.2.2.ebuild31
3 files changed, 37 insertions, 34 deletions
diff --git a/dev-python/pyifp/ChangeLog b/dev-python/pyifp/ChangeLog
index 1edc8334d0b5..8e2be3670138 100644
--- a/dev-python/pyifp/ChangeLog
+++ b/dev-python/pyifp/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pyifp
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyifp/ChangeLog,v 1.7 2011/01/01 21:21:14 arfrever Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyifp/ChangeLog,v 1.8 2015/02/18 01:46:57 idella4 Exp $
+
+*pyifp-0.2.2-r1 (18 Feb 2015)
+
+ 18 Feb 2015; Ian Delaney <idella4@gentoo.org> +pyifp-0.2.2-r1.ebuild,
+ -pyifp-0.2.2.ebuild:
+ revbump; convert -> distutils-r1, rm old
01 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
pyifp-0.2.2.ebuild:
@@ -27,4 +33,3 @@
24 Jan 2006; Patrick McLean <chutzpah@gentoo.org>
+files/pyifp-0.2.2-setup-fix.patch, +metadata.xml, +pyifp-0.2.2.ebuild:
Initial version.
-
diff --git a/dev-python/pyifp/pyifp-0.2.2-r1.ebuild b/dev-python/pyifp/pyifp-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..1a2d588bb228
--- /dev/null
+++ b/dev-python/pyifp/pyifp-0.2.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyifp/pyifp-0.2.2-r1.ebuild,v 1.1 2015/02/18 01:46:57 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for libifp library for accessing iRiver iFP devices"
+HOMEPAGE="http://ifp-gnome.sourceforge.net"
+SRC_URI="mirror://sourceforge/ifp-gnome/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~x86"
+IUSE=""
+
+RDEPEND=">=media-libs/libifp-1.0.0.2"
+DEPEND="${RDEPEND}
+ dev-lang/swig"
+
+pkg_setup() {
+ python-single-r1_pkg_setup
+}
+
+PATCHES=( "${FILESDIR}"/${P}-setup-fix.patch )
diff --git a/dev-python/pyifp/pyifp-0.2.2.ebuild b/dev-python/pyifp/pyifp-0.2.2.ebuild
deleted file mode 100644
index 774833a8f9f1..000000000000
--- a/dev-python/pyifp/pyifp-0.2.2.ebuild
+++ /dev/null
@@ -1,31 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyifp/pyifp-0.2.2.ebuild,v 1.6 2011/01/01 21:21:14 arfrever Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.* *-jython"
-
-inherit eutils distutils
-
-DESCRIPTION="Python bindings for libifp library for accessing iRiver iFP devices"
-HOMEPAGE="http://ifp-gnome.sourceforge.net"
-SRC_URI="mirror://sourceforge/ifp-gnome/${P}.tar.gz"
-
-LICENSE="LGPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~ia64 ~x86"
-IUSE=""
-
-RDEPEND=">=media-libs/libifp-1.0.0.2"
-DEPEND="${RDEPEND}
- dev-lang/swig"
-
-DOCS="README.txt"
-PYTHON_MODNAME="ifp.py ifp_core.py usb_core.py"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-setup-fix.patch
- distutils_src_prepare
-}