summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2014-09-30 11:28:17 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2014-09-30 11:28:17 +0000
commit3e0c7ec2ed677df6ededb2b528fce0d9492a76e5 (patch)
treee105b556573187d9dedbedbe06aee8f8eb5375e3 /dev-python/pyinsane
parentVersion bump, drop old (diff)
downloadgentoo-2-3e0c7ec2ed677df6ededb2b528fce0d9492a76e5.tar.gz
gentoo-2-3e0c7ec2ed677df6ededb2b528fce0d9492a76e5.tar.bz2
gentoo-2-3e0c7ec2ed677df6ededb2b528fce0d9492a76e5.zip
Initial commit, based on lorelei overlay version
(Portage version: 2.2.14_rc1/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'dev-python/pyinsane')
-rw-r--r--dev-python/pyinsane/ChangeLog10
-rw-r--r--dev-python/pyinsane/metadata.xml17
-rw-r--r--dev-python/pyinsane/pyinsane-1.3.8.ebuild20
3 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/pyinsane/ChangeLog b/dev-python/pyinsane/ChangeLog
new file mode 100644
index 000000000000..bdeae51e8c19
--- /dev/null
+++ b/dev-python/pyinsane/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for dev-python/pyinsane
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinsane/ChangeLog,v 1.1 2014/09/30 11:28:17 voyageur Exp $
+
+*pyinsane-1.3.8 (30 Sep 2014)
+
+ 30 Sep 2014; Bernard Cafarelli <voyageur@gentoo.org> +pyinsane-1.3.8.ebuild,
+ +metadata.xml:
+ Initial commit, based on lorelei overlay version
+
diff --git a/dev-python/pyinsane/metadata.xml b/dev-python/pyinsane/metadata.xml
new file mode 100644
index 000000000000..208b318c944c
--- /dev/null
+++ b/dev-python/pyinsane/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+ </maintainer>
+ <longdescription lang="en">
+Python implementation of the Sane API (using ctypes) and abstration layer.
+
+The code is divided in 3 layers:
+
+ * rawapi : Ctypes binding to the raw Sane API
+ * abstract : An Object-Oriented layer that simplifies the use of the Sane API and try to avoid possible misuse of the Sane API. When scanning, it also takes care of returning a Pillow image.
+ * abstract_th : The Sane API is not thread-safe and cannot be used in a multi-threaded environment easily. This layer solves this problem by using a fully dedicated thread.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/pyinsane/pyinsane-1.3.8.ebuild b/dev-python/pyinsane/pyinsane-1.3.8.ebuild
new file mode 100644
index 000000000000..9ca4d81a3980
--- /dev/null
+++ b/dev-python/pyinsane/pyinsane-1.3.8.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyinsane/pyinsane-1.3.8.ebuild,v 1.1 2014/09/30 11:28:17 voyageur Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the Sane API and abstration layer"
+HOMEPAGE="https://github.com/jflesch/pyinsane"
+SRC_URI="https://github.com/jflesch/pyinsane/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="media-gfx/sane-backends
+ virtual/python-imaging"
+DEPEND="${RDEPEND}"