summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2015-07-03 03:54:31 +0000
committerIan Delaney <idella4@gentoo.org>2015-07-03 03:54:31 +0000
commit851a9ecb2478d6a064a2753a90a107da052a185f (patch)
tree9be43cfb83c1226a0579d0849f393c66b9b585a3 /dev-python/pympler
parentVersion bump. (diff)
downloadgentoo-2-851a9ecb2478d6a064a2753a90a107da052a185f.tar.gz
gentoo-2-851a9ecb2478d6a064a2753a90a107da052a185f.tar.bz2
gentoo-2-851a9ecb2478d6a064a2753a90a107da052a185f.zip
bump
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pympler')
-rw-r--r--dev-python/pympler/ChangeLog8
-rw-r--r--dev-python/pympler/pympler-0.4.1.ebuild43
-rw-r--r--dev-python/pympler/pympler-0.4.ebuild4
3 files changed, 52 insertions, 3 deletions
diff --git a/dev-python/pympler/ChangeLog b/dev-python/pympler/ChangeLog
index 97751068d830..117371cf13cd 100644
--- a/dev-python/pympler/ChangeLog
+++ b/dev-python/pympler/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pympler
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/ChangeLog,v 1.27 2015/06/07 15:30:52 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/ChangeLog,v 1.28 2015/07/03 03:54:31 idella4 Exp $
+
+*pympler-0.4.1 (03 Jul 2015)
+
+ 03 Jul 2015; Ian Delaney <idella4@gentoo.org> +pympler-0.4.1.ebuild,
+ pympler-0.4.ebuild:
+ bump
07 Jun 2015; Justin Lecher <jlec@gentoo.org> metadata.xml:
Add github to remote-id in metadata.xml
diff --git a/dev-python/pympler/pympler-0.4.1.ebuild b/dev-python/pympler/pympler-0.4.1.ebuild
new file mode 100644
index 000000000000..3979aeaced49
--- /dev/null
+++ b/dev-python/pympler/pympler-0.4.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/pympler-0.4.1.ebuild,v 1.1 2015/07/03 03:54:31 idella4 Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+MY_PN="Pympler"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Memory profiling for Python applications"
+HOMEPAGE="http://code.google.com/p/pympler/ https://pypi.python.org/pypi/Pympler https://github.com/pympler/pympler"
+SRC_URI="mirror://pypi/P/${MY_PN}/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="doc test"
+
+RDEPEND="dev-python/bottle[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND} )"
+
+S="${WORKDIR}"/${MY_P}
+
+python_prepare_all() {
+ rm pympler/util/bottle.py || die
+ sed \
+ -e '/import bottle/s:^.*$:import bottle:g' \
+ -i pympler/web.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ esetup.py try
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pympler/pympler-0.4.ebuild b/dev-python/pympler/pympler-0.4.ebuild
index d2aaa506e68a..ea1c701ad9e9 100644
--- a/dev-python/pympler/pympler-0.4.ebuild
+++ b/dev-python/pympler/pympler-0.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/pympler-0.4.ebuild,v 1.1 2015/04/08 05:11:47 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pympler/pympler-0.4.ebuild,v 1.2 2015/07/03 03:54:31 idella4 Exp $
EAPI=5
@@ -34,7 +34,7 @@ python_prepare_all() {
}
python_test() {
- esetup.py try || die
+ esetup.py try
}
python_install_all() {