summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-01-27 12:21:23 +0000
committerJeroen Roovers <jer@gentoo.org>2011-01-27 12:21:23 +0000
commitc21aa39ac9020483cca848b1d99f2c55ecd0426e (patch)
treea8a3c3eb6bf7898de7a1830b3249dfc3baf4a2f1 /dev-python/pyparted
parentVersion bump. Fixes bug #352940. (diff)
downloadgentoo-2-c21aa39ac9020483cca848b1d99f2c55ecd0426e.tar.gz
gentoo-2-c21aa39ac9020483cca848b1d99f2c55ecd0426e.tar.bz2
gentoo-2-c21aa39ac9020483cca848b1d99f2c55ecd0426e.zip
Version bump.
(Portage version: 2.2.0_alpha19/cvs/Linux i686)
Diffstat (limited to 'dev-python/pyparted')
-rw-r--r--dev-python/pyparted/ChangeLog9
-rw-r--r--dev-python/pyparted/pyparted-3.5.ebuild35
2 files changed, 42 insertions, 2 deletions
diff --git a/dev-python/pyparted/ChangeLog b/dev-python/pyparted/ChangeLog
index dadeae603aff..e15d168b1b87 100644
--- a/dev-python/pyparted/ChangeLog
+++ b/dev-python/pyparted/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-python/pyparted
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.57 2010/10/29 18:46:37 halcy0n Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/ChangeLog,v 1.58 2011/01/27 12:21:23 jer Exp $
+
+*pyparted-3.5 (27 Jan 2011)
+
+ 27 Jan 2011; Jeroen Roovers <jer@gentoo.org> +pyparted-3.5.ebuild:
+ Version bump.
29 Oct 2010; Mark Loeser <halcy0n@gentoo.org> pyparted-3.4.ebuild:
Mark ~ppc64; bug #300106
diff --git a/dev-python/pyparted/pyparted-3.5.ebuild b/dev-python/pyparted/pyparted-3.5.ebuild
new file mode 100644
index 000000000000..bebf72088615
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.5.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyparted/pyparted-3.5.ebuild,v 1.1 2011/01/27 12:21:23 jer Exp $
+
+EAPI="2"
+
+inherit autotools multilib python
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://fedorahosted.org/pyparted/"
+SRC_URI="https://fedorahosted.org/releases/p/y/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DEPEND="
+ sys-libs/ncurses
+ >=dev-lang/python-2.4
+ >=sys-block/parted-2.3
+ dev-python/decorator
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ sed -i -e 's/-avoid-version/& -shared /' src/Makefile.am || die "sed failed"
+ eautoreconf
+}
+
+src_install() {
+ python_need_rebuild
+ emake DESTDIR="${D}" install || die "emake install failed"
+ python_clean_installation_image
+ dodoc ChangeLog NEWS README TODO
+}