summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-06-01 11:44:01 +0000
committerAmadeusz Piotr Żołnowski <aidecoe@gentoo.org>2012-06-01 11:44:01 +0000
commit87d04853a79652b4e533d15518f4a6ed60853701 (patch)
tree13e894f16c8eef422d20b16e035fde83d2717c6d /dev-python/pyro
parentRemoved old versions in the slot 3. (diff)
downloadgentoo-2-87d04853a79652b4e533d15518f4a6ed60853701.tar.gz
gentoo-2-87d04853a79652b4e533d15518f4a6ed60853701.tar.bz2
gentoo-2-87d04853a79652b4e533d15518f4a6ed60853701.zip
Removed old versions in the slot 4 with exception to the stable one.
(Portage version: 2.1.10.63/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/pyro')
-rw-r--r--dev-python/pyro/ChangeLog6
-rw-r--r--dev-python/pyro/pyro-4.11.ebuild86
-rw-r--r--dev-python/pyro/pyro-4.12.ebuild86
3 files changed, 5 insertions, 173 deletions
diff --git a/dev-python/pyro/ChangeLog b/dev-python/pyro/ChangeLog
index a0f179ff08a5..7658013b3807 100644
--- a/dev-python/pyro/ChangeLog
+++ b/dev-python/pyro/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/pyro
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.64 2012/06/01 11:35:41 aidecoe Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/ChangeLog,v 1.65 2012/06/01 11:44:01 aidecoe Exp $
+
+ 01 Jun 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> -pyro-4.11.ebuild,
+ -pyro-4.12.ebuild:
+ Removed old versions in the slot 4 with exception to the stable one.
01 Jun 2012; Amadeusz Żołnowski <aidecoe@gentoo.org> -pyro-3.13.ebuild,
-pyro-3.15.ebuild:
diff --git a/dev-python/pyro/pyro-4.11.ebuild b/dev-python/pyro/pyro-4.11.ebuild
deleted file mode 100644
index f3db2c7b432b..000000000000
--- a/dev-python/pyro/pyro-4.11.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.11.ebuild,v 1.1 2012/02/08 05:09:52 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45]"
-
-inherit distutils
-
-MY_PN="Pyro4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="!dev-python/pyro:0"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? (
- dev-python/coverage
- dev-python/nose
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="Pyro4"
-
-src_prepare() {
- distutils_src_prepare
-
- sed -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' -i tests/run_suite.py
-
- # Disable tests requiring network connection.
- sed \
- -e "s/testBCstart/_&/" \
- -e "s/testDaemonPyroObj/_&/" \
- -e "s/testLookupAndRegister/_&/" \
- -e "s/testMulti/_&/" \
- -e "s/testRefuseDottedNames/_&/" \
- -e "s/testResolve/_&/" \
- -i tests/PyroTests/test_naming.py
- sed \
- -e "s/testOwnloopBasics/_&/" \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/test_naming2.py
-
- sed \
- -e "s/testServerConnections/_&/" \
- -e "s/testServerParallelism/_&/" \
- -i tests/PyroTests/test_server.py
-
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/test_socket.py
-}
-
-src_test() {
- cd tests
-
- testing() {
- "$(PYTHON)" run_suite.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}
diff --git a/dev-python/pyro/pyro-4.12.ebuild b/dev-python/pyro/pyro-4.12.ebuild
deleted file mode 100644
index 65cf6b263f30..000000000000
--- a/dev-python/pyro/pyro-4.12.ebuild
+++ /dev/null
@@ -1,86 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyro/pyro-4.12.ebuild,v 1.1 2012/03/09 09:26:53 patrick Exp $
-
-EAPI="3"
-PYTHON_DEPEND="*:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.[45]"
-
-inherit distutils
-
-MY_PN="Pyro4"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Advanced and powerful Distributed Object Technology system written entirely in Python"
-HOMEPAGE="http://www.xs4all.nl/~irmen/pyro/ http://pypi.python.org/pypi/Pyro4"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="4"
-KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-
-RDEPEND="!dev-python/pyro:0"
-DEPEND="${RDEPEND}
- dev-python/setuptools
- test? (
- dev-python/coverage
- dev-python/nose
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-PYTHON_MODNAME="Pyro4"
-
-src_prepare() {
- distutils_src_prepare
-
- sed -e '/sys.path.insert/a sys.path.insert(1,"PyroTests")' -i tests/run_suite.py
-
- # Disable tests requiring network connection.
- sed \
- -e "s/testBCstart/_&/" \
- -e "s/testDaemonPyroObj/_&/" \
- -e "s/testLookupAndRegister/_&/" \
- -e "s/testMulti/_&/" \
- -e "s/testRefuseDottedNames/_&/" \
- -e "s/testResolve/_&/" \
- -i tests/PyroTests/test_naming.py
- sed \
- -e "s/testOwnloopBasics/_&/" \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/test_naming2.py
-
- sed \
- -e "s/testServerConnections/_&/" \
- -e "s/testServerParallelism/_&/" \
- -i tests/PyroTests/test_server.py
-
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/test_socket.py
-}
-
-src_test() {
- cd tests
-
- testing() {
- "$(PYTHON)" run_suite.py
- }
- python_execute_function testing
-}
-
-src_install() {
- distutils_src_install
-
- if use doc; then
- dohtml -r docs/* || die "Installation of documentation failed"
- fi
-
- if use examples; then
- insinto /usr/share/doc/${PF}
- doins -r examples || die "Installation of examples failed"
- fi
-}