summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-11-14 07:30:40 +0000
committerIan Delaney <idella4@gentoo.org>2013-11-14 07:30:40 +0000
commit3ecdbdb5427d6fa08dcd3dd4e6d47d724dff9079 (patch)
treeaf3365432fa66459e7c905c6fa8fd4cd33c90561 /dev-python/pysendfile/pysendfile-2.0.0.ebuild
parentAdded 4.6.4 ebuild (but no fixing of the older ones yet). (diff)
downloadgentoo-2-3ecdbdb5427d6fa08dcd3dd4e6d47d724dff9079.tar.gz
gentoo-2-3ecdbdb5427d6fa08dcd3dd4e6d47d724dff9079.tar.bz2
gentoo-2-3ecdbdb5427d6fa08dcd3dd4e6d47d724dff9079.zip
New dep to testsuite of glance, ebuild prepped by me
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pysendfile/pysendfile-2.0.0.ebuild')
-rw-r--r--dev-python/pysendfile/pysendfile-2.0.0.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/pysendfile/pysendfile-2.0.0.ebuild b/dev-python/pysendfile/pysendfile-2.0.0.ebuild
new file mode 100644
index 000000000000..dab679db9bdf
--- /dev/null
+++ b/dev-python/pysendfile/pysendfile-2.0.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysendfile/pysendfile-2.0.0.ebuild,v 1.1 2013/11/14 07:30:40 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} pypy2_0 )
+
+inherit distutils-r1
+
+DESCRIPTION="A python interface to sendfile(2) system call"
+HOMEPAGE="http://code.google.com/p/pysendfile/"
+SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+LICENSE="MIT"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+python_test() {
+# "${PYTHON}" test/test_sendfile.py || die "tests failed under ${EPYTHON}"
+ nosetests test/test_sendfile.py || die "tests failed under ${EPYTHON}"
+}