summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-29 04:14:37 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-29 04:14:37 +0000
commitfda14391ea69aea0e95c1b5c03d2a1441aa2fe5b (patch)
tree933c0c722b5a1d3e95efe011a057e014f2450d91 /dev-python/pyspf
parentBump (diff)
downloadgentoo-2-fda14391ea69aea0e95c1b5c03d2a1441aa2fe5b.tar.gz
gentoo-2-fda14391ea69aea0e95c1b5c03d2a1441aa2fe5b.tar.bz2
gentoo-2-fda14391ea69aea0e95c1b5c03d2a1441aa2fe5b.zip
bump; update, fine tune deps
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/pyspf')
-rw-r--r--dev-python/pyspf/ChangeLog9
-rw-r--r--dev-python/pyspf/pyspf-2.0.10.ebuild (renamed from dev-python/pyspf/pyspf-2.0.8-r1.ebuild)16
-rw-r--r--dev-python/pyspf/pyspf-2.0.5.ebuild24
-rw-r--r--dev-python/pyspf/pyspf-2.0.6.ebuild24
-rw-r--r--dev-python/pyspf/pyspf-2.0.7-r1.ebuild30
-rw-r--r--dev-python/pyspf/pyspf-2.0.8.ebuild28
6 files changed, 16 insertions, 115 deletions
diff --git a/dev-python/pyspf/ChangeLog b/dev-python/pyspf/ChangeLog
index 4d5250542903..8a1268350bc0 100644
--- a/dev-python/pyspf/ChangeLog
+++ b/dev-python/pyspf/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/pyspf
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/ChangeLog,v 1.26 2014/05/03 05:58:57 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/ChangeLog,v 1.27 2014/09/29 04:14:37 idella4 Exp $
+
+*pyspf-2.0.10 (29 Sep 2014)
+
+ 29 Sep 2014; Ian Delaney <idella4@gentoo.org> +pyspf-2.0.10.ebuild,
+ -pyspf-2.0.5.ebuild, -pyspf-2.0.6.ebuild, -pyspf-2.0.7-r1.ebuild,
+ -pyspf-2.0.8-r1.ebuild, -pyspf-2.0.8.ebuild:
+ bump; update, fine tune deps
*pyspf-2.0.9 (03 May 2014)
diff --git a/dev-python/pyspf/pyspf-2.0.8-r1.ebuild b/dev-python/pyspf/pyspf-2.0.10.ebuild
index d35146153837..cce246252cb3 100644
--- a/dev-python/pyspf/pyspf-2.0.8-r1.ebuild
+++ b/dev-python/pyspf/pyspf-2.0.10.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.8-r1.ebuild,v 1.2 2014/04/19 18:11:21 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.10.ebuild,v 1.1 2014/09/29 04:14:37 idella4 Exp $
EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7,3_2,3_3} )
-PYTHON_REQ_USE="ipv6" # Required for tests
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+PYTHON_REQ_USE="ipv6?"
inherit distutils-r1
DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
@@ -15,20 +15,20 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="PSF-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="test"
+IUSE="ipv6 test"
# >=python-3.3 comes with the built-in ipaddress module
RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/ipaddr[${PYTHON_USEDEP}]' 'python2*' python3_2)
- $(python_gen_cond_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]' 'python2*')
+ $(python_gen_cond_dep '>=dev-python/ipaddr-2.1.10[${PYTHON_USEDEP}]' python2_7)
+ $(python_gen_cond_dep 'dev-python/pydns:2[${PYTHON_USEDEP}]' python2_7)
$(python_gen_cond_dep 'dev-python/pydns:3[${PYTHON_USEDEP}]' 'python3*')"
DEPEND="test? ( ${RDEPEND}
dev-python/pyyaml[${PYTHON_USEDEP}] )"
+REQUIRED_USE="test? ( ipv6 )"
+
python_test() {
- # if a 'run' makes it to the end and there are test failures, this will always return 0.
- # A patch is planned for submitting upstream. This state won't occur in most cases.
pushd test &> /dev/null
"${PYTHON}" testspf.py || die
popd &> /dev/null
diff --git a/dev-python/pyspf/pyspf-2.0.5.ebuild b/dev-python/pyspf/pyspf-2.0.5.ebuild
deleted file mode 100644
index d4a30e0fa274..000000000000
--- a/dev-python/pyspf/pyspf-2.0.5.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.5.ebuild,v 1.6 2012/05/09 03:20:55 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.*"
-
-inherit distutils
-
-DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
-HOMEPAGE="http://pypi.python.org/pypi/pyspf"
-SRC_URI="mirror://sourceforge/pymilter/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE=""
-
-DEPEND="|| ( dev-python/pydns:2 dev-python/pydns:0 )"
-RDEPEND="${DEPEND}"
-
-PYTHON_MODNAME="spf.py"
diff --git a/dev-python/pyspf/pyspf-2.0.6.ebuild b/dev-python/pyspf/pyspf-2.0.6.ebuild
deleted file mode 100644
index e9e1e700832b..000000000000
--- a/dev-python/pyspf/pyspf-2.0.6.ebuild
+++ /dev/null
@@ -1,24 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.6.ebuild,v 1.3 2012/05/09 03:20:55 floppym Exp $
-
-EAPI="3"
-PYTHON_DEPEND="2:2.6"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="2.5 3.*"
-
-inherit distutils
-
-DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
-HOMEPAGE="http://pypi.python.org/pypi/pyspf"
-SRC_URI="mirror://sourceforge/pymilter/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND="|| ( dev-python/pydns:2 dev-python/pydns:0 )"
-RDEPEND="${DEPEND}"
-
-PYTHON_MODNAME="spf.py"
diff --git a/dev-python/pyspf/pyspf-2.0.7-r1.ebuild b/dev-python/pyspf/pyspf-2.0.7-r1.ebuild
deleted file mode 100644
index 623901e5ce9a..000000000000
--- a/dev-python/pyspf/pyspf-2.0.7-r1.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.7-r1.ebuild,v 1.1 2013/04/05 08:31:58 idella4 Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
-HOMEPAGE="http://pypi.python.org/pypi/pyspf"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
- || ( dev-python/pydns:2 dev-python/pydns:0 )"
-DEPEND="${DEPEND}
- test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/${P}-catch_unicode.patch )
-
-python_test() {
- pushd test &> /dev/null
- "${PYTHON}" testspf.py || die
- popd &> /dev/null
-}
diff --git a/dev-python/pyspf/pyspf-2.0.8.ebuild b/dev-python/pyspf/pyspf-2.0.8.ebuild
deleted file mode 100644
index 35cab37dd252..000000000000
--- a/dev-python/pyspf/pyspf-2.0.8.ebuild
+++ /dev/null
@@ -1,28 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pyspf/pyspf-2.0.8.ebuild,v 1.1 2014/02/24 06:05:44 patrick Exp $
-
-EAPI="5"
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python implementation of the Sender Policy Framework (SPF) protocol"
-HOMEPAGE="http://pypi.python.org/pypi/pyspf"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="PSF-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/authres[${PYTHON_USEDEP}]
- || ( dev-python/pydns:2 dev-python/pydns:0 )"
-DEPEND="${DEPEND}
- test? ( dev-python/pyyaml[${PYTHON_USEDEP}] )"
-
-python_test() {
- pushd test &> /dev/null
- "${PYTHON}" testspf.py || die
- popd &> /dev/null
-}