summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2002-11-17 09:12:05 +0000
committerMike Frysinger <vapier@gentoo.org>2002-11-17 09:12:05 +0000
commitf70548ea3f5b078c6cbe2ef38f4bc3b9e8488fdc (patch)
treef8b2f1be4426cbeb95a30223d46b8de3504fc6b0 /dev-python/pysqlite
parentChanged mkdir ${D} to dodir ${D} (diff)
downloadgentoo-2-f70548ea3f5b078c6cbe2ef38f4bc3b9e8488fdc.tar.gz
gentoo-2-f70548ea3f5b078c6cbe2ef38f4bc3b9e8488fdc.tar.bz2
gentoo-2-f70548ea3f5b078c6cbe2ef38f4bc3b9e8488fdc.zip
Changed mkdir ${D} to dodir ${D}
Diffstat (limited to 'dev-python/pysqlite')
-rw-r--r--dev-python/pysqlite/pysqlite-0.2.0-r1.ebuild17
1 files changed, 8 insertions, 9 deletions
diff --git a/dev-python/pysqlite/pysqlite-0.2.0-r1.ebuild b/dev-python/pysqlite/pysqlite-0.2.0-r1.ebuild
index b14b1a0a34ef..a9f2dbaa8be9 100644
--- a/dev-python/pysqlite/pysqlite-0.2.0-r1.ebuild
+++ b/dev-python/pysqlite/pysqlite-0.2.0-r1.ebuild
@@ -1,29 +1,28 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-0.2.0-r1.ebuild,v 1.2 2002/11/03 19:27:01 roughneck Exp $
-
-S="${WORKDIR}/${P}"
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pysqlite/pysqlite-0.2.0-r1.ebuild,v 1.3 2002/11/17 09:09:52 vapier Exp $
DESCRIPTION="Python wrapper for the local database Sqlite"
SRC_URI="mirror://sourceforge/pysqlite/pysqlite-${PV}.tar.gz"
HOMEPAGE="http://www.hwaci.com/sw/sqlite/"
-DEPEND="virtual/python
- dev-db/sqlite"
-RDEPEND=""
+
KEYWORDS="ppc x86 sparc sparc64 alpha"
LICENSE="pysqlite"
SLOT="0"
+DEPEND="virtual/python
+ dev-db/sqlite"
+
src_compile() {
python setup.py build || die
}
-src_install () {
+src_install() {
python setup.py install --root=${D} --prefix=/usr || die
dodoc README
-
+
# Need to do the examples explicitly since dodoc
# doesn't do directories properly
- mkdir -p ${D}/usr/share/doc/${PF}/examples || die
+ dodir /usr/share/doc/${PF}/examples || die
cp -r ${S}/examples/* ${D}/usr/share/doc/${PF}/examples || die
}