summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLukasz Strzygowski <lucass@gentoo.org>2007-05-05 08:53:44 +0000
committerLukasz Strzygowski <lucass@gentoo.org>2007-05-05 08:53:44 +0000
commitcbd580ceda2079db3ca133d60ec336e1596bb32f (patch)
tree95504dbafd3f72cb6118e4dc0231276d46de6681 /dev-python/pytables/pytables-1.4.ebuild
parentMinor cleanup. Keyworded ~amd64 (bug #176459). (diff)
downloadgentoo-2-cbd580ceda2079db3ca133d60ec336e1596bb32f.tar.gz
gentoo-2-cbd580ceda2079db3ca133d60ec336e1596bb32f.tar.bz2
gentoo-2-cbd580ceda2079db3ca133d60ec336e1596bb32f.zip
Added: NEED_PYTHON, doc/examples use-flags, ~amd64 keyword. Dropped old versions.
(Portage version: 2.1.2.5)
Diffstat (limited to 'dev-python/pytables/pytables-1.4.ebuild')
-rw-r--r--dev-python/pytables/pytables-1.4.ebuild33
1 files changed, 28 insertions, 5 deletions
diff --git a/dev-python/pytables/pytables-1.4.ebuild b/dev-python/pytables/pytables-1.4.ebuild
index 86af179e9d58..25b2e3254e42 100644
--- a/dev-python/pytables/pytables-1.4.ebuild
+++ b/dev-python/pytables/pytables-1.4.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-1.4.ebuild,v 1.1 2007/04/23 19:24:07 pythonhead Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytables/pytables-1.4.ebuild,v 1.2 2007/05/05 08:53:44 lucass Exp $
+
+NEED_PYTHON=2.2
inherit distutils
@@ -8,12 +10,33 @@ DESCRIPTION="Module for Python that use HDF5"
SRC_URI="mirror://sourceforge/pytables/${P}.tar.gz"
HOMEPAGE="http://pytables.sourceforge.net/"
-DEPEND=">=dev-lang/python-2.2
- >=sys-devel/gcc-3.2
+DEPEND=">=sys-devel/gcc-3.2
sci-libs/hdf5
>=dev-python/numarray-1.0"
SLOT="0"
-KEYWORDS="~ia64 ~ppc ~x86"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86"
LICENSE="as-is"
-IUSE=""
+IUSE="doc examples"
+DOCS="ANNOUNCE.txt RELEASE-NOTES.txt THANKS TODO.txt VERSION"
+
+src_install() {
+ distutils_src_install
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+
+ if use doc; then
+ cd doc
+
+ dohtml -r html/*
+
+ docinto text
+ dodoc text/*
+
+ insinto /usr/share/doc/${PF}
+ doins -r usersguide.pdf scripts/
+ fi
+}