summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2012-11-06 09:26:13 +0000
committerIan Delaney <idella4@gentoo.org>2012-11-06 09:26:13 +0000
commit037ffebd31d5b42dbd80887552b4d5c2ab0adc7a (patch)
treef025e7024c171ce6195eabe33f77d74191d8e408 /dev-python/pytest
parentBuild with boost-1.50 Bug #425454 (diff)
downloadgentoo-2-037ffebd31d5b42dbd80887552b4d5c2ab0adc7a.tar.gz
gentoo-2-037ffebd31d5b42dbd80887552b4d5c2ab0adc7a.tar.bz2
gentoo-2-037ffebd31d5b42dbd80887552b4d5c2ab0adc7a.zip
rev bump, doc flag added, building of docs added, minor update to test phase
(Portage version: 2.1.11.30/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'dev-python/pytest')
-rw-r--r--dev-python/pytest/ChangeLog8
-rw-r--r--dev-python/pytest/pytest-2.3.2-r1.ebuild63
2 files changed, 70 insertions, 1 deletions
diff --git a/dev-python/pytest/ChangeLog b/dev-python/pytest/ChangeLog
index c60bc2a9a3be..8d4f2a055416 100644
--- a/dev-python/pytest/ChangeLog
+++ b/dev-python/pytest/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/pytest
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.38 2012/10/30 08:05:44 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/ChangeLog,v 1.39 2012/11/06 09:26:13 idella4 Exp $
+
+*pytest-2.3.2-r1 (07 Nov 2012)
+
+ 07 Nov 2012; Ian Delaney <idella4@gentoo.org> +pytest-2.3.2-r1.ebuild,
+ pytest-2.3.2.ebuild:
+ rev bump, doc flag added, building of docs added, minor update to test phase
*pytest-2.3.2 (30 Oct 2012)
diff --git a/dev-python/pytest/pytest-2.3.2-r1.ebuild b/dev-python/pytest/pytest-2.3.2-r1.ebuild
new file mode 100644
index 000000000000..65a9f8a3d106
--- /dev/null
+++ b/dev-python/pytest/pytest-2.3.2-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/pytest/pytest-2.3.2-r1.ebuild,v 1.1 2012/11/06 09:26:13 idella4 Exp $
+
+EAPI="3"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+DESCRIPTION="py.test: simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/ http://pypi.python.org/pypi/pytest"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x86-macos"
+IUSE="doc"
+
+RDEPEND=">=dev-python/py-1.4.7"
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-python/setuptools"
+
+DOCS="CHANGELOG README.txt"
+PYTHON_MODNAME="pytest.py _pytest"
+
+src_prepare() {
+ distutils_src_prepare
+
+ # Disable versioning of py.test script to avoid collision with versioning performed by distutils_src_install().
+ sed -e "s/return points/return {'py.test': target}/" -i setup.py || die "sed failed"
+}
+
+src_compile() {
+ distutils_src_compile
+
+ dodocs() {
+ if [[ "${PYTHON_ABI}" == "2.7" ]]; then
+ mkdir doc/en/.build || die
+ PYTHONPATH="${S}/doc:${S}/build-${PYTHON_ABI}"/lib emake -C doc/en html
+ fi
+ }
+ use doc && python_execute_function dodocs
+}
+
+src_test() {
+ testing() {
+ local exit_status=0
+ PYTHONPATH="${S}/build-${PYTHON_ABI}/lib" "$(PYTHON)" build-${PYTHON_ABI}/lib/pytest.py || exit_status=1
+ return $exit_status
+ }
+ python_execute_function testing
+}
+
+src_install() {
+ distutils_src_install
+ python_generate_wrapper_scripts -E -f -q "${ED}usr/bin/py.test"
+
+ # Bug 380275: Test suite pre-compiles modules
+ python_clean_installation_image -q
+
+ use doc && dohtml -r doc/en/_build/html/
+}