summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2014-04-27 05:57:48 +0000
committerMatthew Thode <prometheanfire@gentoo.org>2014-04-27 05:57:48 +0000
commit4d19a3d6bcd09297469703c9c2a38e97874f0a24 (patch)
treec2983bd105f1b349abcf7d7e02ac1052e0bb3c41 /dev-python/python-ceilometerclient
parentupdating clients (diff)
downloadgentoo-2-4d19a3d6bcd09297469703c9c2a38e97874f0a24.tar.gz
gentoo-2-4d19a3d6bcd09297469703c9c2a38e97874f0a24.tar.bz2
gentoo-2-4d19a3d6bcd09297469703c9c2a38e97874f0a24.zip
updating clients
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x2471eb3e40ac5ac3)
Diffstat (limited to 'dev-python/python-ceilometerclient')
-rw-r--r--dev-python/python-ceilometerclient/ChangeLog10
-rw-r--r--dev-python/python-ceilometerclient/python-ceilometerclient-1.0.10.ebuild44
-rw-r--r--dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild48
-rw-r--r--dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6.ebuild26
4 files changed, 53 insertions, 75 deletions
diff --git a/dev-python/python-ceilometerclient/ChangeLog b/dev-python/python-ceilometerclient/ChangeLog
index 08502df1dc9b..db6eed8cadd6 100644
--- a/dev-python/python-ceilometerclient/ChangeLog
+++ b/dev-python/python-ceilometerclient/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-python/python-ceilometerclient
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ceilometerclient/ChangeLog,v 1.3 2014/03/19 23:09:31 bicatali Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ceilometerclient/ChangeLog,v 1.4 2014/04/27 05:57:48 prometheanfire Exp $
+
+*python-ceilometerclient-1.0.10 (27 Apr 2014)
+
+ 27 Apr 2014; Matthew Thode <prometheanfire@gentoo.org>
+ +python-ceilometerclient-1.0.10.ebuild,
+ -python-ceilometerclient-1.0.6-r1.ebuild,
+ -python-ceilometerclient-1.0.6.ebuild:
+ updating clients
19 Mar 2014; Sébastien Fabbro <bicatali@gentoo.org>
python-ceilometerclient-1.0.6-r1.ebuild:
diff --git a/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.10.ebuild b/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.10.ebuild
new file mode 100644
index 000000000000..ceb6603f7162
--- /dev/null
+++ b/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.10.ebuild,v 1.1 2014/04/27 05:57:48 prometheanfire Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client library for Ceilometer built on the Ceilometer API."
+HOMEPAGE="https://github.com/openstack/python-ceilometerclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.6[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( >=dev-python/hacking-0.8.0[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.9[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/subunit-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ <dev-python/sphinx-1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.18[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.34[${PYTHON_USEDEP}]
+ )"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.7[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.6.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2.7"
+ flake8 ceilometerclient/tests/ || die "run over tests folder by flake8 yielded error"
+}
diff --git a/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild b/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild
deleted file mode 100644
index 668034f608a0..000000000000
--- a/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild,v 1.2 2014/03/19 23:09:31 bicatali Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="This is a client library for Ceilometer built on the Ceilometer API."
-HOMEPAGE="https://github.com/openstack/python-ceilometerclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]
- test? ( =dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
- <dev-python/pyflakes-0.7.4[${PYTHON_USEDEP}]
- =dev-python/flake8-2.0[${PYTHON_USEDEP}]
- >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
- <dev-python/hacking-0.8[${PYTHON_USEDEP}]
- >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
- >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
- >=dev-python/mock-1.0[${PYTHON_USEDEP}]
- >=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
- dev-python/subunit[${PYTHON_USEDEP}]
- >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
- >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
- >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
- )"
-RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-0.3.2[${PYTHON_USEDEP}]"
-
-python_test() {
- testr init
- testr run || die "tests failed under python2.7"
- flake8 ceilometerclient/tests/ || die "run over tests folder by flake8 yielded error"
-}
diff --git a/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6.ebuild b/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6.ebuild
deleted file mode 100644
index 6a122e9d88c9..000000000000
--- a/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6.ebuild,v 1.1 2013/10/23 05:56:58 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="This is a client library for Ceilometer built on the Ceilometer API."
-HOMEPAGE="https://github.com/openstack/python-ceilometerclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
- <dev-python/pbr-1.0[${PYTHON_USEDEP}]"
-RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- dev-python/httplib2[${PYTHON_USEDEP}]
- >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-0.3.2[${PYTHON_USEDEP}]"