summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-12-03 15:00:33 +0000
committerIan Delaney <idella4@gentoo.org>2013-12-03 15:00:33 +0000
commit95093897a50e7675c4e0ce608fd45e81b22ba7b9 (patch)
treea384a4e8e1a12b7979ce1043c827ebd5a1b67342 /dev-python/python-ceilometerclient
parentfix to test phase, thx to Chicago for reporting flaw (diff)
downloadgentoo-2-95093897a50e7675c4e0ce608fd45e81b22ba7b9.tar.gz
gentoo-2-95093897a50e7675c4e0ce608fd45e81b22ba7b9.tar.bz2
gentoo-2-95093897a50e7675c4e0ce608fd45e81b22ba7b9.zip
revbump; add IUSE test, test deps, test phase, thanks to Chicago for reporting
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-ceilometerclient')
-rw-r--r--dev-python/python-ceilometerclient/ChangeLog8
-rw-r--r--dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/dev-python/python-ceilometerclient/ChangeLog b/dev-python/python-ceilometerclient/ChangeLog
index 4fa8a86f3207..bb39864b19cf 100644
--- a/dev-python/python-ceilometerclient/ChangeLog
+++ b/dev-python/python-ceilometerclient/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-ceilometerclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ceilometerclient/ChangeLog,v 1.1 2013/10/23 05:56:58 prometheanfire Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ceilometerclient/ChangeLog,v 1.2 2013/12/03 15:00:33 idella4 Exp $
+
+*python-ceilometerclient-1.0.6-r1 (03 Dec 2013)
+
+ 03 Dec 2013; Ian Delaney <idella4@gentoo.org>
+ +python-ceilometerclient-1.0.6-r1.ebuild:
+ revbump; add IUSE test, test deps, test phase, thanks to Chicago for reporting
*python-ceilometerclient-1.0.6 (23 Oct 2013)
diff --git a/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild b/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild
new file mode 100644
index 000000000000..beb543f3be34
--- /dev/null
+++ b/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ceilometerclient/python-ceilometerclient-1.0.6-r1.ebuild,v 1.1 2013/12/03 15:00:33 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This is a client library for Ceilometer built on the Ceilometer API."
+HOMEPAGE="https://github.com/openstack/python-ceilometerclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ test? ( =dev-python/pep8-1.4.5[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-0.7.4[${PYTHON_USEDEP}]
+ =dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.8[${PYTHON_USEDEP}]
+ >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/fixtures-0.3.14[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0[${PYTHON_USEDEP}]
+ >=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
+ dev-python/subunit[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ )"
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ dev-python/httplib2[${PYTHON_USEDEP}]
+ >=dev-python/iso8601-0.1.4[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.3.2[${PYTHON_USEDEP}]"
+
+python_test() {
+ testr init
+ testr run || die "tests failed under python2.7"
+ flake8 ceilometerclient/tests/ || die "run over tests folder by flake8 yielded error"
+}