summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-31 18:33:57 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-05-31 18:33:57 +0000
commit546ca084eb61a519e698eed2428f844745edff10 (patch)
tree29aafe84245829cbce150e07bc3f0e890a55af57 /dev-python/python-daap
parenthppa stable, #308521 (diff)
downloadgentoo-2-546ca084eb61a519e698eed2428f844745edff10.tar.gz
gentoo-2-546ca084eb61a519e698eed2428f844745edff10.tar.bz2
gentoo-2-546ca084eb61a519e698eed2428f844745edff10.zip
Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-daap')
-rw-r--r--dev-python/python-daap/ChangeLog8
-rw-r--r--dev-python/python-daap/python-daap-0.7.1.ebuild30
2 files changed, 20 insertions, 18 deletions
diff --git a/dev-python/python-daap/ChangeLog b/dev-python/python-daap/ChangeLog
index 3c96980e9b86..083e64199a3c 100644
--- a/dev-python/python-daap/ChangeLog
+++ b/dev-python/python-daap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-python/python-daap
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-daap/ChangeLog,v 1.3 2008/11/24 17:52:18 ssuominen Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-daap/ChangeLog,v 1.4 2010/05/31 18:33:57 arfrever Exp $
+
+ 31 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ python-daap-0.7.1.ebuild:
+ Set SUPPORT_PYTHON_ABIS.
24 Nov 2008; <ssuominen@gentoo.org> metadata.xml:
Re-assign to sound and python herds.
diff --git a/dev-python/python-daap/python-daap-0.7.1.ebuild b/dev-python/python-daap/python-daap-0.7.1.ebuild
index 64de1f01dfee..3801b848c65a 100644
--- a/dev-python/python-daap/python-daap-0.7.1.ebuild
+++ b/dev-python/python-daap/python-daap-0.7.1.ebuild
@@ -1,12 +1,14 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-daap/python-daap-0.7.1.ebuild,v 1.1 2008/05/27 15:05:53 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-daap/python-daap-0.7.1.ebuild,v 1.2 2010/05/31 18:33:57 arfrever Exp $
-NEED_PYTHON=2.4
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
-inherit distutils multilib python
+inherit distutils
-MY_P=PythonDaap-${PV}
+MY_P="PythonDaap-${PV}"
DESCRIPTION="PyDaap is a DAAP client implemented in Python, based on PyTunes"
HOMEPAGE="http://jerakeen.org/code/pythondaap"
@@ -17,7 +19,13 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="examples"
-S=${WORKDIR}/${MY_P}
+DEPEND=""
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+S="${WORKDIR}/${MY_P}"
+
+PYTHON_MODNAME="daap.py"
src_install() {
distutils_src_install
@@ -27,13 +35,3 @@ src_install() {
doins -r examples
fi
}
-
-pkg_postinst() {
- python_version
- python_mod_optimize "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages
-}
-
-pkg_postrm() {
- python_version
- python_mod_cleanup /usr/$(get_libdir)/python${PYVER}/site-packages
-}