summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2004-01-03 03:47:40 +0000
committerAlastair Tse <liquidx@gentoo.org>2004-01-03 03:47:40 +0000
commita16bc2e060610c030db71d381500a6630ebd485c (patch)
treea1253c394377e86e9bfae26afc8b63f65e4b0914 /dev-python/python-docs/python-docs-2.3.3.ebuild
parentfix sed for CXXFLAGS; fix config location; more error checking/messages (diff)
downloadgentoo-2-a16bc2e060610c030db71d381500a6630ebd485c.tar.gz
gentoo-2-a16bc2e060610c030db71d381500a6630ebd485c.tar.bz2
gentoo-2-a16bc2e060610c030db71d381500a6630ebd485c.zip
version bump and keyword for arm
Diffstat (limited to 'dev-python/python-docs/python-docs-2.3.3.ebuild')
-rw-r--r--dev-python/python-docs/python-docs-2.3.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/python-docs/python-docs-2.3.3.ebuild b/dev-python/python-docs/python-docs-2.3.3.ebuild
new file mode 100644
index 000000000000..add5c10276f6
--- /dev/null
+++ b/dev-python/python-docs/python-docs-2.3.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-docs/python-docs-2.3.3.ebuild,v 1.1 2004/01/03 03:47:40 liquidx Exp $
+
+DESCRIPTION="HTML documentation for Python"
+SRC_URI="http://www.python.org/ftp/python/doc/${PV}/html-${PV}.tar.bz2"
+HOMEPAGE="http://www.python.org/doc/2.3/"
+
+IUSE=""
+SLOT="2.3"
+KEYWORDS="~x86 ~ppc" # ~sparc ~alpha ~hppa ~ia64 ~amd64"
+LICENSE="PSF-2.2"
+
+DEPEND=""
+RDEPEND=""
+S=${WORKDIR}
+
+src_install() {
+ docinto html
+ cp -R ${S}/* ${D}/usr/share/doc/${PF}/html
+ dodir /etc/env.d
+ echo "PYTHONDOCS=/usr/share/doc/${PF}/html" > ${D}/etc/env.d/50python-docs
+}