summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-10-31 23:40:05 +0000
committerMichał Górny <mgorny@gentoo.org>2012-10-31 23:40:05 +0000
commit3c49c3b1abb522ff606ea9f021d8a186301cc5c3 (patch)
treee530e884b475eb6f380e50552571f55560aef68c /dev-python/python-exec/python-exec-0.1.1.ebuild
parentLet encfs get the correct boost installed. (diff)
downloadgentoo-2-3c49c3b1abb522ff606ea9f021d8a186301cc5c3.tar.gz
gentoo-2-3c49c3b1abb522ff606ea9f021d8a186301cc5c3.tar.bz2
gentoo-2-3c49c3b1abb522ff606ea9f021d8a186301cc5c3.zip
Version bump. The new version adds Prefix support and respect preferred Python2 & 3 choices as well.
(Portage version: 2.2.0_alpha142/cvs/Linux x86_64, signed Manifest commit with key 42B9401D)
Diffstat (limited to 'dev-python/python-exec/python-exec-0.1.1.ebuild')
-rw-r--r--dev-python/python-exec/python-exec-0.1.1.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/python-exec/python-exec-0.1.1.ebuild b/dev-python/python-exec/python-exec-0.1.1.ebuild
new file mode 100644
index 000000000000..6ce96e738268
--- /dev/null
+++ b/dev-python/python-exec/python-exec-0.1.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-exec/python-exec-0.1.1.ebuild,v 1.1 2012/10/31 23:40:05 mgorny Exp $
+
+EAPI=4
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Python script wrapper"
+HOMEPAGE="https://bitbucket.org/mgorny/python-exec/"
+SRC_URI="mirror://bitbucket/mgorny/${PN}/downloads/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE=""
+
+append_impl() {
+ pyimpls+="${EPYTHON} "
+}
+
+src_configure() {
+ local pyimpls
+ python_foreach_impl append_impl
+
+ local myeconfargs=(
+ --with-eprefix="${EPREFIX}"
+ --with-python-impls="${pyimpls}"
+ )
+
+ autotools-utils_src_configure
+}