summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-11-30 09:48:57 +0000
committerIan Delaney <idella4@gentoo.org>2013-11-30 09:48:57 +0000
commit8eddd1691002af524521297336f67b1f5195333c (patch)
tree1669f8686608f42cebe9c1f0874aeac55ac1949f /dev-python/python-glanceclient
parentVersion bump of slf4j-nop to 1.7.5 (diff)
downloadgentoo-2-8eddd1691002af524521297336f67b1f5195333c.tar.gz
gentoo-2-8eddd1691002af524521297336f67b1f5195333c.tar.bz2
gentoo-2-8eddd1691002af524521297336f67b1f5195333c.zip
bump; update deps, remove old
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-glanceclient')
-rw-r--r--dev-python/python-glanceclient/ChangeLog9
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild4
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild45
-rw-r--r--dev-python/python-glanceclient/python-glanceclient-0.12.0.ebuild65
4 files changed, 75 insertions, 48 deletions
diff --git a/dev-python/python-glanceclient/ChangeLog b/dev-python/python-glanceclient/ChangeLog
index ddb749a3a684..c5bacacb0712 100644
--- a/dev-python/python-glanceclient/ChangeLog
+++ b/dev-python/python-glanceclient/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-glanceclient
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/ChangeLog,v 1.7 2013/11/28 13:03:45 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/ChangeLog,v 1.8 2013/11/30 09:48:57 idella4 Exp $
+
+*python-glanceclient-0.12.0 (30 Nov 2013)
+
+ 30 Nov 2013; Ian Delaney <idella4@gentoo.org>
+ +python-glanceclient-0.12.0.ebuild, -python-glanceclient-0.10.0.ebuild,
+ python-glanceclient-0.10.0-r1.ebuild:
+ bump; update deps, remove old
*python-glanceclient-0.10.0-r1 (28 Nov 2013)
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild
index 0aa811be6a9d..ccbe9e8b85e6 100644
--- a/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild
+++ b/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild,v 1.1 2013/11/28 13:03:45 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.10.0-r1.ebuild,v 1.2 2013/11/30 09:48:57 idella4 Exp $
EAPI=5
PYTHON_COMPAT=( python2_7 )
@@ -31,7 +31,7 @@ DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
dev-python/mox[${PYTHON_USEDEP}]
>=dev-python/mock-0.8.0[${PYTHON_USEDEP}]
)
- doc? ( dev-python/sphinx )
+ doc? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] )
"
RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
>=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild
deleted file mode 100644
index f5a3a5ea6b0f..000000000000
--- a/dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.10.0.ebuild,v 1.1 2013/08/11 01:43:36 prometheanfire Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-#tests restricted due to unpackaged deps
-RESTRICT="test"
-DESCRIPTION="A client for the OpenStack Glance API"
-HOMEPAGE="https://github.com/openstack/python-glanceclient"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-# test? ( dev-python/mox
-# dev-python/coverage
-# dev-python/discover #not packaged
-# =dev-python/pep8-1.3.3
-# >=dev-python/setuptools-git-0.4
-# >=dev-python/sphinx-1.1.2
-# >=dev-python/testrepository-0.0.13 #not packaged
-# >=dev-python/testtools-0.9.22 )"
-RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
- >=dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
- <dev-python/d2to1-0.3[${PYTHON_USEDEP}]
- >=dev-python/pbr-0.5[${PYTHON_USEDEP}]
- <dev-python/pbr-0.6[${PYTHON_USEDEP}]
- >=dev-python/python-keystoneclient-0.2.1[${PYTHON_USEDEP}]
- <dev-python/python-keystoneclient-1[${PYTHON_USEDEP}]
- >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
- <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
- dev-python/pyopenssl[${PYTHON_USEDEP}]
- >=dev-python/warlock-0.7.0[${PYTHON_USEDEP}]
- <dev-python/warlock-2[${PYTHON_USEDEP}]"
-
-#python_test() {
-# "${PYTHON}" setup.py nosetests || die
-#}
diff --git a/dev-python/python-glanceclient/python-glanceclient-0.12.0.ebuild b/dev-python/python-glanceclient/python-glanceclient-0.12.0.ebuild
new file mode 100644
index 000000000000..a57b9615b30e
--- /dev/null
+++ b/dev-python/python-glanceclient/python-glanceclient-0.12.0.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-glanceclient/python-glanceclient-0.12.0.ebuild,v 1.1 2013/11/30 09:48:57 idella4 Exp $
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A client for the OpenStack Glance API"
+HOMEPAGE="https://github.com/openstack/python-glanceclient"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( >=dev-python/coverage-3.6[${PYTHON_USEDEP}]
+ >=dev-python/pep8-1.3.3[${PYTHON_USEDEP}]
+ >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}]
+ =dev-python/d2to1-0.2.10[${PYTHON_USEDEP}]
+ <dev-python/d2to1-0.3[${PYTHON_USEDEP}]
+ >=dev-python/testrepository-0.0.17[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.32[${PYTHON_USEDEP}]
+ =dev-python/pyflakes-0.7.2[${PYTHON_USEDEP}]
+ >=dev-python/flake8-2.0[${PYTHON_USEDEP}]
+ >=dev-python/hacking-0.5.6[${PYTHON_USEDEP}]
+ <dev-python/hacking-0.7[${PYTHON_USEDEP}]
+ >=dev-python/mox-0.5.3[${PYTHON_USEDEP}]
+ >=dev-python/mock-0.8.03[${PYTHON_USEDEP}]
+ )
+ doc? ( >=dev-python/sphinx-1.1.2[${PYTHON_USEDEP}] )
+ "
+RDEPEND="virtual/python-argparse[${PYTHON_USEDEP}]
+ >=dev-python/pbr-0.5.21[${PYTHON_USEDEP}]
+ <dev-python/pbr-1.0[${PYTHON_USEDEP}]
+ >=dev-python/python-keystoneclient-0.3.0[${PYTHON_USEDEP}]
+ <dev-python/python-keystoneclient-1[${PYTHON_USEDEP}]
+ >=dev-python/prettytable-0.6[${PYTHON_USEDEP}]
+ <dev-python/prettytable-0.8[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ >=dev-python/warlock-1.0.1[${PYTHON_USEDEP}]
+ <dev-python/warlock-2[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+ sed -e 's:intersphinx_mapping:_&:' -i doc/source/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ testr init
+ testr run || die "testsuite failed under python2.7"
+ flake8 tests && einfo "run flake8 over tests folder passed" || die
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/build/html/. )
+ distutils-r1_python_install_all
+}