summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-08-17 21:47:11 +0000
committerMichał Górny <mgorny@gentoo.org>2013-08-17 21:47:11 +0000
commit6fde52dfc279df570794a584c38418c16f1b1e5a (patch)
tree06dad4f0e756a10acc23ee70b9b7c76aec150d83 /dev-python/python-iwscan
parentConditionalize '--enable-migration-from-qemu-kvm' (not an upstream option). (diff)
downloadgentoo-2-6fde52dfc279df570794a584c38418c16f1b1e5a.tar.gz
gentoo-2-6fde52dfc279df570794a584c38418c16f1b1e5a.tar.bz2
gentoo-2-6fde52dfc279df570794a584c38418c16f1b1e5a.zip
Convert to distutils-r1.
(Portage version: 2.2.0/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'dev-python/python-iwscan')
-rw-r--r--dev-python/python-iwscan/ChangeLog8
-rw-r--r--dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild29
2 files changed, 36 insertions, 1 deletions
diff --git a/dev-python/python-iwscan/ChangeLog b/dev-python/python-iwscan/ChangeLog
index 44f286c56a99..b901657b6c6e 100644
--- a/dev-python/python-iwscan/ChangeLog
+++ b/dev-python/python-iwscan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-iwscan
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/ChangeLog,v 1.14 2013/06/02 10:57:25 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/ChangeLog,v 1.15 2013/08/17 21:47:11 mgorny Exp $
+
+*python-iwscan-20080402-r1 (17 Aug 2013)
+
+ 17 Aug 2013; Michał Górny <mgorny@gentoo.org>
+ +python-iwscan-20080402-r1.ebuild:
+ Convert to distutils-r1.
02 Jun 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due bug #328951
diff --git a/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild b/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild
new file mode 100644
index 000000000000..e0c2f6c5d75e
--- /dev/null
+++ b/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-iwscan/python-iwscan-20080402-r1.ebuild,v 1.1 2013/08/17 21:47:11 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="A Python extension for iwscan access"
+HOMEPAGE="http://projects.otaku42.de/browser/python-iwscan"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND="net-wireless/wireless-tools"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-wireless-tools-30.patch"
+)
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}