summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nelson <jnelson@gentoo.org>2002-08-02 02:12:11 +0000
committerJon Nelson <jnelson@gentoo.org>2002-08-02 02:12:11 +0000
commit0b5258d30b571c15762d066db91f57024053974a (patch)
tree8fd455cb6adca5c77411e534d4560fb4b8c94e78 /dev-python/python-ldap
parentnew upstream (1.4.2) and fix repoman errors in new 1.4.2 ebuild (diff)
downloadgentoo-2-0b5258d30b571c15762d066db91f57024053974a.tar.gz
gentoo-2-0b5258d30b571c15762d066db91f57024053974a.tar.bz2
gentoo-2-0b5258d30b571c15762d066db91f57024053974a.zip
fix repoman errors in pre05 release and bump to pre05
Diffstat (limited to 'dev-python/python-ldap')
-rw-r--r--dev-python/python-ldap/ChangeLog9
-rw-r--r--dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre051
-rw-r--r--dev-python/python-ldap/python-ldap-2.0.0_pre05.ebuild28
3 files changed, 35 insertions, 3 deletions
diff --git a/dev-python/python-ldap/ChangeLog b/dev-python/python-ldap/ChangeLog
index e61ea6546750..6bf4de46fb97 100644
--- a/dev-python/python-ldap/ChangeLog
+++ b/dev-python/python-ldap/ChangeLog
@@ -1,11 +1,14 @@
# ChangeLog for dev-python/python-ldap
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.1 2002/04/04 02:43:30 blocke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/ChangeLog,v 1.2 2002/08/02 02:12:11 jnelson Exp $
+*python-ldap-2.0.0pre05 (1 Aug 2002)
+
+ 1 Aug 2002; Jon Nelson <jnelson@gentoo.org> python-ldap-2.0.0pre05.ebuild:
+ Update to pre05 and fix repoman errors in *this* release
+
*python-ldap-2.0.0pre04 (3 Apr 2002)
3 Apr 2002; Bruce A. Locke <blocke@shivan.org> python-ldap-2.0.0pre04.ebuild :
Initial Version
-
-
diff --git a/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre05 b/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre05
new file mode 100644
index 000000000000..a0023f32cbb7
--- /dev/null
+++ b/dev-python/python-ldap/files/digest-python-ldap-2.0.0_pre05
@@ -0,0 +1 @@
+MD5 8de6fb19e415a84e1cfc73264c0573df python-ldap-2.0.0pre05.tar.gz 46111
diff --git a/dev-python/python-ldap/python-ldap-2.0.0_pre05.ebuild b/dev-python/python-ldap/python-ldap-2.0.0_pre05.ebuild
new file mode 100644
index 000000000000..0c495cabab46
--- /dev/null
+++ b/dev-python/python-ldap/python-ldap-2.0.0_pre05.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ldap/python-ldap-2.0.0_pre05.ebuild,v 1.1 2002/08/02 02:12:11 jnelson Exp $
+
+VERSION="2.0.0pre05"
+S=${WORKDIR}/${PN}-${VERSION}
+DESCRIPTION="Various LDAP-related Python modules"
+SRC_URI="mirror://sourceforge/python-ldap/python-ldap-${VERSION}.tar.gz"
+HOMEPAGE="http://python-ldap.sourceforge.net/"
+
+DEPEND="virtual/python
+ >=net-nds/openldap-2.0.11"
+RDEPEND="${DEPEND}"
+SLOT="0"
+LICENSE="public-domain" # NOTE: win32 section is under questionable license
+KEYWORDS="x86"
+
+src_compile() {
+
+ mv setup.cfg setup.cfg.orig
+ sed -e "s|/usr/local/openldap2/lib|/usr/lib|" \
+ -e "s|/usr/local/openldap2/include|/usr/include|" > setup.cfg \
+ || die
+
+ base_src_compile
+}
+
+inherit distutils