summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2014-12-01 02:02:53 +0000
committerMike Gilbert <floppym@gentoo.org>2014-12-01 02:02:53 +0000
commit9ae0297632024a58f431278d95114625ddd8b35d (patch)
tree14e2cf7315adeaa2d4f404b1e29218dd34026470 /dev-python/python-ptrace
parentversion bump (diff)
downloadgentoo-2-9ae0297632024a58f431278d95114625ddd8b35d.tar.gz
gentoo-2-9ae0297632024a58f431278d95114625ddd8b35d.tar.bz2
gentoo-2-9ae0297632024a58f431278d95114625ddd8b35d.zip
Drop optional runtime dep on dev-libs/distorm64, and restore python3 and pypy support. Remove old.
(Portage version: 2.2.14/cvs/Linux x86_64, signed Manifest commit with key 0BBEEA1FEA4843A4)
Diffstat (limited to 'dev-python/python-ptrace')
-rw-r--r--dev-python/python-ptrace/ChangeLog8
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.6.6.ebuild45
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.7.ebuild32
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.8.1.ebuild13
-rw-r--r--dev-python/python-ptrace/python-ptrace-0.8.ebuild33
5 files changed, 12 insertions, 119 deletions
diff --git a/dev-python/python-ptrace/ChangeLog b/dev-python/python-ptrace/ChangeLog
index 8a3df778a3c9..4bc1982eaf55 100644
--- a/dev-python/python-ptrace/ChangeLog
+++ b/dev-python/python-ptrace/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-ptrace
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.17 2014/11/30 16:55:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/ChangeLog,v 1.18 2014/12/01 02:02:53 floppym Exp $
+
+ 01 Dec 2014; Mike Gilbert <floppym@gentoo.org> -python-ptrace-0.6.6.ebuild,
+ -python-ptrace-0.7.ebuild, -python-ptrace-0.8.ebuild,
+ python-ptrace-0.8.1.ebuild:
+ Drop optional runtime dep on dev-libs/distorm64, and restore python3 and pypy
+ support. Remove old.
30 Nov 2014; Michał Górny <mgorny@gentoo.org> python-ptrace-0.7.ebuild,
python-ptrace-0.8.1.ebuild, python-ptrace-0.8.ebuild:
diff --git a/dev-python/python-ptrace/python-ptrace-0.6.6.ebuild b/dev-python/python-ptrace/python-ptrace-0.6.6.ebuild
deleted file mode 100644
index ab301b29f94e..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.6.6.ebuild
+++ /dev/null
@@ -1,45 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.6.6.ebuild,v 1.2 2014/08/10 21:19:40 slyfox Exp $
-
-EAPI="3"
-SUPPORT_PYTHON_ABIS="1"
-
-inherit distutils eutils
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)"
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64"
-RESTRICT_PYTHON_ABIS="2.4"
-
-DISTUTILS_USE_SEPARATE_SOURCE_DIRECTORIES="1"
-PYTHON_MODNAME="ptrace"
-
-src_prepare() {
- python_copy_sources
-
- conversion() {
- [[ "${PYTHON_ABI}" == 2.* ]] && return
-
- 2to3-${PYTHON_ABI} -w . > /dev/null || die "2to3 failed"
- 2to3-${PYTHON_ABI} -dw . > /dev/null || die "2to3 failed"
- }
- python_execute_function --action-message 'Applying patches for Python ${PYTHON_ABI}' --failure-message 'Applying patches for Python ${PYTHON_ABI} failed' -s conversion
-}
-
-src_install() {
- distutils_src_install
-
- if use examples; then
- insinto usr/share/doc/${PF}/examples
- doins examples/*
- fi
-}
diff --git a/dev-python/python-ptrace/python-ptrace-0.7.ebuild b/dev-python/python-ptrace/python-ptrace-0.7.ebuild
deleted file mode 100644
index 509c770886bf..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.7.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.7.ebuild,v 1.3 2014/11/30 16:55:05 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)"
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="examples"
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64[${PYTHON_USEDEP}]"
-# Req'd for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- "${PYTHON}" test_doc.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}
diff --git a/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild b/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild
index d16292903b97..1d350a6f790b 100644
--- a/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild
+++ b/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild,v 1.2 2014/11/30 16:55:05 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.8.1.ebuild,v 1.3 2014/12/01 02:02:53 floppym Exp $
EAPI=5
-PYTHON_COMPAT=( python2_7 )
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
inherit distutils-r1
@@ -16,13 +16,10 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc examples"
-DEPEND=""
-RDEPEND="dev-libs/distorm64[${PYTHON_USEDEP}]"
-# Req'd for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
python_test() {
- "${PYTHON}" test_doc.py || die "tests failed under ${EPYTHON}"
+ # Python 3.4 adds SOCK_CLOEXEC to socket.type automatically, and ptrace does
+ # not translate that on output causing it to fail test_strace.test_socket.
+ "${PYTHON}" runtests.py || die "Testing failed with ${EPYTHON}"
}
python_install_all() {
diff --git a/dev-python/python-ptrace/python-ptrace-0.8.ebuild b/dev-python/python-ptrace/python-ptrace-0.8.ebuild
deleted file mode 100644
index f6a5482dcfb5..000000000000
--- a/dev-python/python-ptrace/python-ptrace-0.8.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-ptrace/python-ptrace-0.8.ebuild,v 1.2 2014/11/30 16:55:05 mgorny Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="python-ptrace is a debugger using ptrace (Linux, BSD and Darwin system call to trace processes)"
-HOMEPAGE="http://bitbucket.org/haypo/python-ptrace/ http://pypi.python.org/pypi/python-ptrace"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="doc examples"
-
-DEPEND=""
-RDEPEND="dev-libs/distorm64[${PYTHON_USEDEP}]"
-# Req'd for tests
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_test() {
- "${PYTHON}" test_doc.py || die "tests failed under ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
- # doc folder missing key files to effect a proper doc build
- use doc && local DOCS=( README doc/* )
- distutils-r1_python_install_all
-}