summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2013-02-05 11:48:32 +0000
committerIan Delaney <idella4@gentoo.org>2013-02-05 11:48:32 +0000
commit04ea0958b9a1976465a59d4b7891e6afeaf37a8d (patch)
tree19960899ab1705f5f4e8119906ed810566926f55 /dev-python/python-xlib
parentversion bump (diff)
downloadgentoo-2-04ea0958b9a1976465a59d4b7891e6afeaf37a8d.tar.gz
gentoo-2-04ea0958b9a1976465a59d4b7891e6afeaf37a8d.tar.bz2
gentoo-2-04ea0958b9a1976465a59d4b7891e6afeaf37a8d.zip
Add file defs to newly made files/ by virtue of upstream missing it in the source tarball in -0.15_rc1-r1, fix to jobserver issue by sed statement, fixes Bug #454836 by flameeyes, see https://sourceforge.net/p/python-xlib/bugs/39/
(Portage version: 2.1.11.40/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-python/python-xlib')
-rw-r--r--dev-python/python-xlib/ChangeLog10
-rw-r--r--dev-python/python-xlib/files/defs11
-rw-r--r--dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild10
3 files changed, 27 insertions, 4 deletions
diff --git a/dev-python/python-xlib/ChangeLog b/dev-python/python-xlib/ChangeLog
index cca94ef270e2..0eee5b66c3c7 100644
--- a/dev-python/python-xlib/ChangeLog
+++ b/dev-python/python-xlib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-python/python-xlib
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/ChangeLog,v 1.38 2011/08/15 08:00:58 xarthisius Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/ChangeLog,v 1.39 2013/02/05 11:48:32 idella4 Exp $
+
+ 05 Feb 2013; Ian Delaney <idella4@gentoo.org> +files/defs,
+ python-xlib-0.15_rc1-r1.ebuild:
+ Add file defs to newly made files/ by virtue of upstream missing it in the
+ source tarball in -0.15_rc1-r1, fix to jobserver issue by sed statement, fixes
+ Bug #454836 by flameeyes, see https://sourceforge.net/p/python-xlib/bugs/39/
15 Aug 2011; Kacper Kowalik <xarthisius@gentoo.org>
python-xlib-0.15_rc1.ebuild:
diff --git a/dev-python/python-xlib/files/defs b/dev-python/python-xlib/files/defs
new file mode 100644
index 000000000000..2da6f932799b
--- /dev/null
+++ b/dev-python/python-xlib/files/defs
@@ -0,0 +1,11 @@
+# Definitions for documentation makefiles
+
+SRCDIR = ../src
+
+TOPSRC = $(SRCDIR)/python-xlib.texi
+
+SRCS = $(TOPSRC) \
+ $(SRCDIR)/concepts.texi $(SRCDIR)/package.texi \
+ $(SRCDIR)/connect.texi $(SRCDIR)/errors.texi \
+ $(SRCDIR)/events.texi $(SRCDIR)/objects.texi
+
diff --git a/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild b/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild
index 4d838a52eea4..bb603b55c944 100644
--- a/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild
+++ b/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2011 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild,v 1.2 2011/04/16 18:49:22 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild,v 1.3 2013/02/05 11:48:32 idella4 Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -29,6 +29,12 @@ RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="Xlib"
+src_prepare() {
+ distutils_src_prepare
+ sed -e 's:make:$(MAKE):g' -i doc/Makefile || die
+ cp -r "${FILESDIR}"/defs doc/src/ || die
+}
+
src_compile() {
distutils_src_compile