summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2011-03-30 14:24:28 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2011-03-30 14:24:28 +0000
commit14c2068c1faeadba70ea04f19a4bb49320a6726a (patch)
treeaca1f31e1b077ccd8c3fd3a68537c8b2e8829173 /dev-python/python-xlib
parentDrop logrotate useflag description too. (diff)
downloadgentoo-2-14c2068c1faeadba70ea04f19a4bb49320a6726a.tar.gz
gentoo-2-14c2068c1faeadba70ea04f19a4bb49320a6726a.tar.bz2
gentoo-2-14c2068c1faeadba70ea04f19a4bb49320a6726a.zip
Rename 0.15_rc1 as 0.15_rc1-r1 and remove USE="doc" from 0.15_rc1 for stabilization wrt #361141, Comment #1 by Agostino Sarubbo.
(Portage version: 2.2.0_alpha29/cvs/Linux x86_64)
Diffstat (limited to 'dev-python/python-xlib')
-rw-r--r--dev-python/python-xlib/ChangeLog11
-rw-r--r--dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild62
-rw-r--r--dev-python/python-xlib/python-xlib-0.15_rc1.ebuild30
3 files changed, 74 insertions, 29 deletions
diff --git a/dev-python/python-xlib/ChangeLog b/dev-python/python-xlib/ChangeLog
index 15b033b4e632..1f71df635f1b 100644
--- a/dev-python/python-xlib/ChangeLog
+++ b/dev-python/python-xlib/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-python/python-xlib
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/ChangeLog,v 1.33 2010/05/28 22:01:02 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/ChangeLog,v 1.34 2011/03/30 14:24:28 ssuominen Exp $
+
+*python-xlib-0.15_rc1-r1 (30 Mar 2011)
+
+ 30 Mar 2011; Samuli Suominen <ssuominen@gentoo.org>
+ python-xlib-0.15_rc1.ebuild, +python-xlib-0.15_rc1-r1.ebuild:
+ Rename 0.15_rc1 as 0.15_rc1-r1 and remove USE="doc" from 0.15_rc1 for
+ stabilization wrt #361141, Comment #1 by Agostino Sarubbo.
28 May 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
python-xlib-0.14.ebuild, python-xlib-0.15_rc1.ebuild:
diff --git a/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild b/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild
new file mode 100644
index 000000000000..fcca205f6f46
--- /dev/null
+++ b/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.15_rc1-r1.ebuild,v 1.1 2011/03/30 14:24:28 ssuominen Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+
+inherit distutils
+
+MY_P="${P/_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="A fully functional X client library for Python, written in Python"
+HOMEPAGE="http://python-xlib.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc"
+
+DEPEND="doc? (
+ virtual/latex-base
+ >=sys-apps/texinfo-4.8-r2
+ )"
+RDEPEND=""
+RESTRICT_PYTHON_ABIS="3.*"
+
+PYTHON_MODNAME="Xlib"
+
+src_compile() {
+ distutils_src_compile
+
+ if use doc; then
+ cd doc
+ einfo "Generation of documentation"
+ VARTEXFONTS="${T}"/fonts emake || die "Generation of documentation failed"
+ fi
+}
+
+src_test() {
+ cd test
+ testing() {
+ local return_status="0" test
+ for test in *.py; do
+ echo "Running ${test}..."
+ PYTHONPATH="../build-${PYTHON_ABI}/lib" "$(PYTHON)" "${test}" || return_status="1"
+ done
+ return "${return_status}"
+ }
+ python_execute_function testing
+}
+
+src_install () {
+ distutils_src_install
+
+ if use doc; then
+ dohtml -r doc/html/
+ dodoc doc/ps/python-xlib.ps
+ fi
+}
diff --git a/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild b/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
index 5102f7a15017..53660a4c3327 100644
--- a/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
+++ b/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild,v 1.2 2010/05/28 22:01:02 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-python/python-xlib/python-xlib-0.15_rc1.ebuild,v 1.3 2011/03/30 14:24:28 ssuominen Exp $
EAPI="3"
PYTHON_DEPEND="2"
@@ -18,27 +18,12 @@ SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86"
-IUSE="doc"
+IUSE=""
-DEPEND="doc? (
- virtual/latex-base
- >=sys-apps/texinfo-4.8-r2
- )"
-RDEPEND=""
RESTRICT_PYTHON_ABIS="3.*"
PYTHON_MODNAME="Xlib"
-src_compile() {
- distutils_src_compile
-
- if use doc; then
- cd doc
- einfo "Generation of documentation"
- VARTEXFONTS="${T}"/fonts emake || die "Generation of documentation failed"
- fi
-}
-
src_test() {
cd test
testing() {
@@ -51,12 +36,3 @@ src_test() {
}
python_execute_function testing
}
-
-src_install () {
- distutils_src_install
-
- if use doc; then
- dohtml -r doc/html/
- dodoc doc/ps/python-xlib.ps
- fi
-}